ViewCreator3d Class
API for creating a 3D default ViewState3d for an iModel. See: ViewCreator2d to create a view for a 2d model. Example usage:
const viewCreator = new ViewCreator3d(imodel);
const defaultView = await viewCreator.createDefaultView({skyboxOn: true});
extensions
Methods
Name | Description | |
---|---|---|
constructor(_imodel: IModelConnection): ViewCreator3d | Constructs a ViewCreator3d using an IModelConnection. | |
createDefaultView(options?: ViewCreator3dOptions, modelIds?: string[]): Promise<ViewState> | Creates a default ViewState3d based on the model ids passed in. |
Defined in
Last Updated: 30 November, 2023