BingElevationProvider Class
Provides an interface to the Bing Maps elevation services. Use of these services requires an API key to be supplied via MapLayerOptions.BingMaps in the IModelAppOptions.mapLayerOptions passed to IModelApp.startup.
extensions
Methods
Name | Description | |
---|---|---|
constructor(): BingElevationProvider | ||
getHeight(carto: Cartographic, geodetic: boolean = true): Promise<any> | Return the height (altitude) at a given cartographic location. | |
getHeightAverage(iModel: IModelConnection): Promise<number> | Get the average height (altitude) for a given iModel project extents. | |
getHeightRange(iModel: IModelConnection): Promise<Range1d> | Get the height (altitude) range for a given iModel project extents. | |
getHeightValue(point: Point3d, iModel: IModelConnection, geodetic: boolean = true): Promise<number> | Get the height (altitude) at a given iModel coordinate. | |
getHeights(range: Range2d): Promise<undefined | number[]> | Returns 256 elevations in the specified range - 16 rows and 16 columns. | Beta |
Defined in
Last Updated: 30 November, 2023