ParseAndRunResult Enumeration
The result type of ToolRegistry.parseAndRun.
extensions
Members
Name | Value | Description |
---|---|---|
Success | 0 | The tool's parseAndRun method was invoked and returned true . |
ToolNotFound | 1 | No tool matching the toolId in the keyin is registered. |
BadArgumentCount | 2 | The number of arguments supplied does not meet the constraints of the Tool. See: Tool.minArgs and Tool.maxArgs. |
FailedToRun | 3 | The tool's parseAndRun method returned false . |
MismatchedQuotes | 4 | An opening double-quote character was not paired with a closing double-quote character. |
Defined in
- core/frontend/src/tools/Tool.ts Line 879
Last Updated: 30 November, 2023