parseAndRun Method
Given a string consisting of a toolId followed by any number of arguments, parse the keyin string and invoke the corresponding tool's parseAndRun
method.
parseAndRun(keyin: string): Promise<ParseAndRunResult>
see ToolRegistry.parseKeyin to parse the keyin string and for a detailed description of the syntax.
throws any Error thrown by the tool's parseAndRun
method.
Parameter | Type | Description |
---|---|---|
keyin | string | A string consisting of a toolId followed by any number of arguments. |
Returns - Promise<ParseAndRunResult>
A status indicating whether the keyin was successfully parsed and executed.
Defined in
- core/frontend/src/tools/Tool.ts Line 1160
Last Updated: 30 November, 2023