BeButtonEvent Class
Object sent to Tools that holds information about button/touch/wheel events.
extensions
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props?: BeButtonEventProps): BeButtonEvent | ||
clone(): BeButtonEvent | Make a copy of this BeButtonEvent. | |
init(props: BeButtonEventProps): void | Initialize the values of this BeButtonEvent. | |
invalidate(): void | Mark this BeButtonEvent as invalid. | |
setFrom(src: BeButtonEvent): BeButtonEvent | Copy the values from another BeButtonEvent into this BeButtonEvent |
Properties
Name | Type | Description | |
---|---|---|---|
button | BeButton | The mouse button that created this event. | |
coordsFrom | CoordSource | How the coordinate values were generated (either from an action by the user or from a program.) | |
inputSource | InputSource | Whether this event came from a pointing device (e.g. | |
isAltKey Accessor ReadOnly | boolean | Determine whether the alt key was pressed | |
isControlKey Accessor ReadOnly | boolean | Determine whether the control key was pressed | |
isDoubleClick | boolean | If true, this is the second down in a rapid double-click of the same button. | |
isDown | boolean | If true, this event was generated from a mouse-down transition, false from a button-up transition. | |
isDragging | boolean | If true, this event was created by pressing, holding, and then moving a mouse button. | |
isShiftKey Accessor ReadOnly | boolean | Determine whether the shift key was pressed | |
isValid Accessor ReadOnly | boolean | Determine whether this BeButtonEvent has valid data. | |
keyModifiers | BeModifierKeys | The keyboard modifiers that were pressed when the event was generated. | |
point Accessor | Point3d | The point for this event, in world coordinates. | |
rawPoint Accessor | Point3d | The raw (unadjusted) point for this event, in world coordinates. | |
viewPoint Accessor | Point3d | The point, in screen coordinates for this event. | |
viewport | undefined | ScreenViewport | The ScreenViewport from which this BeButtonEvent was generated. |
Defined in
- core/frontend/src/tools/Tool.ts Line 148
Last Updated: 30 November, 2023