IModelJson.GeometryProps Interface
Property rules for json objects that can be deserialized to various Curve and Solid objects
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bsurf | undefined | IModelJson.BSplineSurfaceProps | {bsurf:...} |
|
indexedMesh | undefined | IModelJson.IndexedMeshProps | {indexedMesh:...} |
|
point | undefined | XYZProps | {point:...} |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
arc | IModelJson.ArcByVectorProps | [XYZProps, XYZProps, XYZProps] | IModelJson.CurvePrimitiveProps | {arc:...} |
bagofCurves | undefined | [IModelJson.CurveCollectionProps] | CurveCollectionProps | A collection of curves with no required structure or connections: |
bcurve | undefined | IModelJson.BcurveProps | IModelJson.CurvePrimitiveProps | {bcurve:...} |
box | undefined | IModelJson.BoxProps | SolidPrimitiveProps | {box:...} |
cone | undefined | IModelJson.ConeProps | SolidPrimitiveProps | {cone:............} |
cylinder | undefined | IModelJson.CylinderProps | SolidPrimitiveProps | {cylinder:...} |
interpolationCurve | undefined | InterpolationCurve3dProps | IModelJson.CurvePrimitiveProps | `{interpolationCurve:...}~ |
lineSegment | undefined | [XYZProps, XYZProps] | IModelJson.CurvePrimitiveProps | {lineSegment:...} |
lineString | undefined | XYZProps[] | IModelJson.CurvePrimitiveProps | {lineString:...} |
linearSweep | undefined | IModelJson.LinearSweepProps | SolidPrimitiveProps | {linearSweep:.........} |
loop | undefined | [IModelJson.CurvePrimitiveProps] | CurveCollectionProps | {loop:...} |
parityRegion | undefined | [{ loop: [IModelJson.CurvePrimitiveProps] }] | CurveCollectionProps | {parityRegion:...} |
path | undefined | [IModelJson.CurvePrimitiveProps] | CurveCollectionProps | A sequence of curves joined head to tail: |
rotationalSweep | undefined | IModelJson.RotationalSweepProps | SolidPrimitiveProps | {rotationalSweep:...} |
ruledSweep | undefined | IModelJson.RuledSweepProps | SolidPrimitiveProps | {ruledSweep:...} |
sphere | undefined | IModelJson.SphereProps | SolidPrimitiveProps | {sphere:............} |
torusPipe | undefined | IModelJson.TorusPipeProps | SolidPrimitiveProps | {torusPipe:............} |
transitionSpiral | undefined | IModelJson.TransitionSpiralProps | IModelJson.CurvePrimitiveProps | {transitionSpiral:...} |
unionRegion | undefined | [IModelJson.PlanarRegionProps] | CurveCollectionProps | {unionRegion:...} |
Defined in
Last Updated: 30 November, 2023