IModelJson.RotationalSweepProps Interface
Interface for a rotational sweep of a base curve or region around an axis.
Properties
Name | Type | Description | |
---|---|---|---|
axis | XYZProps | The axis of rotation | |
capped | undefined | boolean | flag for circular end caps. | |
center | XYZProps | any point on the axis of rotation. | |
contour | IModelJson.CurveCollectionProps | The swept curve or region. | |
sweepAngle | AngleProps | sweep angle |
Defined in
- serialization/IModelJsonSchema.ts Line 292
Last Updated: 30 November, 2023