IModelJson.CurveCollectionProps Interface
Interface for a collection of curves, eg. as used as a swept contour.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bagofCurves | undefined | [IModelJson.CurveCollectionProps] | A collection of curves with no required structure or connections: | |
path | undefined | [IModelJson.CurvePrimitiveProps] | A sequence of curves joined head to tail: |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
loop | undefined | [IModelJson.CurvePrimitiveProps] | IModelJson.PlanarRegionProps | {loop:...} |
parityRegion | undefined | [{ loop: [IModelJson.CurvePrimitiveProps] }] | IModelJson.PlanarRegionProps | {parityRegion:...} |
unionRegion | undefined | [IModelJson.PlanarRegionProps] | IModelJson.PlanarRegionProps | {unionRegion:...} |
Defined in
- serialization/IModelJsonSchema.ts Line 130
Last Updated: 30 November, 2023