IModelJson.SphereProps Interface
Interface for Sphere (with optionally different radius to pole versus equator)
- Orientation may be given in any
AxesProp
s way (yawPitchRoll, xyVectors, zxVectors)
Extends
Properties
Name | Type | Description | |
---|---|---|---|
capped | undefined | boolean | optional capping flag. | |
center | XYZProps | Center of the sphere coordinate system | |
latitudeStartEnd | undefined | AngleSweepProps | optional sweep range for latitude. | |
radius | undefined | number | primary radius | |
radiusX | undefined | number | optional x radius | |
radiusY | undefined | number | optional y radius | |
radiusZ | undefined | number | optional radius at poles. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | undefined | YawPitchRollProps | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by Z direction then X direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 429
Last Updated: 30 November, 2023