IModelJson.IndexedMeshProps Interface
Interface for an indexed mesh.
- IMPORTANT: All indices are one-based.
- i.e. vertex index given as 11 appears at index 10 in the data array.
- This is to allow a negated index to mean "don't draw the following edge"
- Although negative indices are not allowed for normalIndex, colorIndex, or paramIndex, the "one based" style is used for them so that all indices within the indexedMesh json object are handled similarly.
- In all index arrays, a ZERO indicates "end of facet".
Properties
Name | Type | Description | |
---|---|---|---|
color | undefined | [number] | 32 bit color values | |
colorIndex | undefined | [number] | ONE BASED ZERO TERMINATED array of color indices. | |
normal | undefined | [XYZProps] | surface normals | |
normalIndex | undefined | [number] | ONE BASED ZERO TERMINATED array of normal indices. | |
param | undefined | [XYProps] | texture space (uv parameter) coordinates | |
paramIndex | undefined | [number] | ONE BASED ZERO TERMINATED array of param indices. | |
point | [XYZProps] | vertex coordinates | |
pointIndex | [number] | SIGNED ONE BASED ZERO TERMINATED array of point indices. | |
taggedNumericData | undefined | IModelJson.TaggedNumericDataProps | optional array of tagged geometry (such as to request subdivision surface) |
Defined in
- serialization/IModelJsonSchema.ts Line 511
Last Updated: 30 November, 2023