core-react
Classes
Name | Description | |
---|---|---|
ActivateSettingsTabEvent | Event class for onActivateSettingsTab which is emitted when API call needs to set the active settings tab (ie via Tool key-in). | |
AutoSuggest | Auto Suggest React component. | |
Button | Generic button component | Deprecated |
Checkbox | A React component that renders a simple checkbox with label. | Deprecated |
CheckListBox | React component showing a list of Checkbox items. | |
CheckListBoxItem | Item with a checkbox added to a CheckListBox. | |
ContextMenu | A context menu populated with ContextMenuItem components. | |
ContextMenuDivider | Menu Divider for ContextMenu. | |
ContextMenuItem | Menu Item class for use within a ContextMenu component. | |
ContextSubMenu | Submenu wrapper class for use within a ContextMenu component. | |
Dialog | Dialog React component with optional resizing and dragging functionality | |
ExpandableBlock | ExpandableBlock React component is a container that shows and hides child content. | Deprecated |
ExpandableList | ExpandableList React component is a container for ExpandableBlock components. | |
ExpansionToggle | ExpansionToggle React component used by the TreeNode component to show collapsed or expanded state | |
Field | Component that represents a single field in an input form. | |
Form | Component used to create a Form using supplied properties to specify the fields of the Form. | |
GlobalContextMenu | GlobalContextMenu React component used to display a ContextMenu at the cursor | |
GlobalDialog | GlobalDialog React component used to display a Dialog on the top of screen | |
IconHelper | Icon Helper Class used to store the data needed to generate an |
|
IconWebComponent | IconWebComponent loads icon from an svg path | |
ImageCheckBox | ImageCheckBox React component shows a checked or unchecked image | |
InputLabel | Text input wrapper that provides additional styling and labeling | |
LabeledSelect | Dropdown wrapper that allows for additional styling and labelling | Deprecated |
LabeledToggle | Toggle component with a Label to the right | Deprecated |
LoadingBar | A loading bar with optional percentage text. | |
LoadingPrompt | A component to display during loading that optionally shows percentage, status text and a cancel button. | |
LoadingSpinner | A loading spinner component that optionally shows a text message. | |
LoadingStatus | A loading indicator that shows status text along with the percentage. | |
LocalStateStorage | Implementation of UiStateStorage using Window.localStorage. | |
Message Box React component. | ||
Message Container React component. | ||
Popup | Popup React component displays a popup relative to an optional target element. | |
ProcessSettingsContainerCloseEvent | Event class for onProcessSettingsContainerClose which is emitted when the settings container will be closed. | |
ProcessSettingsTabActivationEvent | Event class for onProcessSettingsTabActivation which is emitted when a new Tab needs to be activated. | |
RadialButton | Button for use within a RadialMenu | |
RadialMenu | A context menu arranged in a radial layout. | |
Radio | Basic radio input component is a wrapper for the <input type="radio"> HTML element. |
Deprecated |
ScrollPositionMaintainer | A helper class to recursively save and restore scroll positions. | |
SearchBox | Input box for entering text to search for. | |
SettingsManager | Settings Manager class. | |
SettingsProvidersChangedEvent | Event class for onSettingsProvidersChanged which is emitted when a new SettingsTabsProvider is added or removed. | |
Spinner | An indeterminate spinner component. | Deprecated |
SplitButton | SplitButton with an action button on the left and an arrow button that displays a context menu on the right. | Deprecated |
SvgPath | Svg element wrapper with specified Svg paths. | |
SvgSprite | Svg element wrapper. | |
Tabs | Tabs meant to represent the current position in a page/section | |
Tile | The Tile React component is a container for rendering elements that can be grouped together. | Beta |
Timer | Notifies handler after a set interval. | |
Tree | Presentation React component for a Tree | |
TreeBranch | Presentation React component for a Tree branch | |
TreeNode | Presentation React component for a Tree node | |
TreeNodePlaceholder | Presentation React component for a placeholder to be displayed instead of a node while it's being loaded | |
UiCore | Manages the Localization service for the core-react package. | |
UiEvent | iTwin.js UI UiEvent class is a subclass of BeEvent with argument type safety. | |
UiStateEntry | A single UI State enter that is identified by namespace and setting name. |
Constants
Name | Description | |
---|---|---|
DivWithOutsideClick | Div element with Outside Click behavior | |
FormContext | React context used by Form as a Provider and by the Fields as Consumers and updaters. |
Enumerations
Name | Description | |
---|---|---|
ButtonSize | Sizes for Button component | Deprecated |
ButtonType | Types for Button component | Deprecated |
CheckBoxState | State of a checkbox | |
ContextMenuDirection | Enum to specify where a ContextMenu should anchor to its parent element | |
DialogAlignment | Enum for dialog alignment | |
DialogButtonStyle | Enum for button style. | Deprecated |
DialogButtonType | Enum for button types. | Deprecated |
HorizontalAlignment | Enumeration for horizontal alignment. | |
InputStatus | Enum for Input status | |
Message Severity enum. | Deprecated | |
Orientation | Enumeration of orientation. | |
SortDirection | Enumeration for sorting direction. | |
SpinnerSize | Size for Spinner component | Deprecated |
TimeFormat | Enumeration of time formats. | |
ToggleButtonType | Toggle display types | Deprecated |
UiStateStorageStatus | Enum for UiStateStorage status. | |
VerticalAlignment | Enumeration for vertical alignment. |
Global Functions
Name | Description | |
---|---|---|
BlockText | Styled block text React functional component | |
BodyText | Styled body text React functional component | |
Centered | Centered React functional component. | |
CheckListBoxSeparator | Separator added to a CheckListBox. | |
DisabledText | Styled disabled text React functional component | |
Div | Base div element React component | |
ElementResizeObserver | ElementResizeObserver provides functionality similar to ReactResizeDetector when a render function is specified. | |
ElementSeparator | A movable button, which allows to change the ratio between left element and right element | |
FeaturedTile | Featured Tile component | Beta |
FillCentered | Full height & width and centered React functional component. | |
FlexWrapContainer | Flex Wrap Container React functional component. | |
Gap | Horizontal gap or space React component. | |
getCssVariable | Get CSS variable | |
getCssVariableAsNumber | Get CSS variable as number | |
Headline | Styled headline text React functional component | Deprecated |
HorizontalTabs | Horizontal tabs meant to represent the current position in a page/section | Deprecated |
Icon | Icon Functional component displays an icon based on an IconSpec. | |
IconInput | Input component with icon to the left of the input field | |
Input | Basic text input, is a wrapper for the <input type="text"> HTML element. |
Deprecated |
LabeledInput | Text input wrapper that provides additional styling and labeling | Deprecated |
LabeledTextarea | Textarea wrapper that allows for additional styling and labelling | Deprecated |
LabeledThemedSelect | Dropdown wrapper that allows for additional styling and labelling | Beta |
LeadingText | Styled leading text React functional component | Deprecated |
LeadingText2 | Styled leading text React functional component | Deprecated |
React component renders a string, HTMLElement or React node in a div or span |
||
MinimalFeaturedTile | Minimal and Featured Tile component | Beta |
MinimalTile | Minimal Tile component | Beta |
MutedText | Styled muted/gray text React functional component | |
NumberInput | Input component for numbers with up and down buttons to increment and decrement the value. | |
PopupContextMenu | Component that displays a ContextMenu within a Popup component, allowing the target element to be specified. | |
ProgressBar | ProgressBar React component shows a horizontal progress bar. | Beta |
ProgressSpinner | Circular Progress Indicator that supports determinate and indeterminate modes. | Beta |
ResizableContainerObserver | ResizableContainerObserver is a component that provides the functionality similar to the ReactResizeDetector option that call a function when | |
ScrollView | Scroll View React functional component. | |
Select | Basic select component is a wrapper for the <select> HTML element. |
Deprecated |
SettingsContainer | SettingsContainer component that displays Setting Tabs on Left and the P | |
Slider | Slider React component displays a range slider. | Deprecated |
SmallText | Styled small text React functional component | Deprecated |
StyledText | The base component for other text components that pass a main CSS class name. | |
Subheading | Styled subheading text React functional component | Deprecated |
Subheading2 | Styled subheading text React functional component | Deprecated |
Textarea | Basic textarea component | Deprecated |
ThemedSelect | ThemedSelect is a wrapper for react-select with iTwin.js UI theming applied | Beta |
Title | Styled title text React functional component | Deprecated |
Title2 | Styled title text React functional component | Deprecated |
Toggle | Toggle React component to show an "on" or "off" state | Deprecated |
Tooltip | Component that displays tooltip for a specified target element. | Beta |
UnderlinedButton | A React component that makes text clickable and underlined | |
useCrossOriginPopup | Hook that will show a popup window | Beta |
useDisposable | A custom hook which creates a disposable object and manages its disposal on unmount | |
useEffectSkipFirst | Custom hook which works like useEffect hook, but does not invoke callback when effect is triggered for the first time. | |
useInterval | Hook that create an interval and clears it when unloaded | Beta |
useOnOutsideClick | Invokes onOutsideClick handler when user clicks outside of referenced element. | |
useOptionalDisposable | A custom hook which calls the factory method to create a disposable object | |
useSaveBeforeActivatingNewSettingsTab | Hook to use within Settings Page component to allow saving the current page's data before loading to the requested Setting Tab's page. | |
useSaveBeforeClosingSettingsContainer | Hook to use within Settings Page component to allow saving the current page's data before the Setting Container is closed. | |
VerticalTabs | Vertical tabs meant to represent the current position in a page/section | |
WebFontIcon | WebFontIcon React component | |
withIsPressed | withIsPressed is a React higher-order component that adds pointer and mouse events. | |
withOnOutsideClick | withOnOutsideClick is a React higher-order component that adds outside click support. | |
withTimeout | withTimeout is a React higher-order component that adds timeout support. |
Interfaces
Name | Description | |
---|---|---|
ActivateSettingsTabEventArgs | Arguments of onActivateSettingsTab event. | |
AutoSuggestData | Data for the AutoSuggest options | |
AutoSuggestProps | Properties for the AutoSuggest component. | |
ButtonProps | Properties for Button component | Deprecated |
CheckBoxInfo | A data type that holds all the checkbox display attributes | |
CheckboxProps | Properties for Checkbox React component | Deprecated |
CheckListBoxItemProps | Properties for the CheckListBoxItem component | |
ClassNameProps | Props used by components that expect class name to be passed in. | |
CommonDivProps | Common properties using a div element. | |
CommonProps | Common props used by components. | |
ContextMenuItemProps | Properties for the ContextMenuItem component | |
ContextMenuProps | Properties for the ContextMenu component | |
ContextSubMenuProps | Properties for the ContextSubMenu component | |
DialogButtonDef | Interface for a dialog button in a button cluster | Deprecated |
DialogProps | Properties for the Dialog component | |
DivProps | Properties for the Div component | |
ElementSeparatorProps | Properties of ElementSeparator React component | |
ExpandableBlockProps | Properties for the ExpandableBlock React component | Deprecated |
ExpandableListProps | Properties for ExpandableList component | |
ExpansionToggleProps | Properties for the ExpansionToggle component | |
FieldDef | Interface used to define each Field in a Form | |
FieldDefinitions | Key/value pairs for all the field definitions to be displayed in a Form. | |
FieldProps | Properties used to create a Field in a Form | |
FieldValues | Key/value pairs for all the field values with key being the field HTML Id. | |
FormContextState | FormContextState combines the Form's state data with the callbacks used to update the value of the state data. | |
FormProps | Properties that define Form including the callback to be called when the Submit button is pressed. | |
GapProps | Properties for the Gap component. | |
GlobalContextMenuProps | Properties for the GlobalContextMenu component | |
GlobalDialogProps | Properties for the GlobalDialog component | |
GlobalDialogState | State properties for the GlobalDialog component | |
IconInputProps | Properties for the IconInput component | |
IconProps | Properties for the Icon React component | |
ImageCheckBoxProps | Properties for the ImageCheckBox component | |
InputLabelProps | Properties for InputLabel components | |
InputProps | Properties for the Input component | Deprecated |
LabeledComponentProps | Properties for labeled components | |
LabeledInputProps | Properties for LabeledInput components | Deprecated |
LabeledSelectProps | Properties for LabeledSelect components | Deprecated |
LabeledTextareaProps | Properties for LabeledTextarea component | Deprecated |
LabeledThemedSelectProps | Properties for LabeledThemedSelect components | Beta |
LabeledToggleProps | Properties for LabeledToggle | Deprecated |
LoadingBarProps | Properties for LoadingBar component | |
LoadingPromptProps | Properties for LoadingPrompt component | |
LoadingSpinnerProps | Properties for LoadingSpinner component | |
LoadingStatusProps | Properties for LoadingStatus component | |
MainTabsProps | Properties for the base Tabs component | |
Properties for the MessageBox component | ||
Properties for the MessageContainer component | ||
Properties for components with messages | ||
Properties for the MessageRenderer component | ||
NoChildrenProps | Props used by components that do not expect children to be passed in. | |
NodeCheckboxProps | Properties for Tree Node CheckBox | |
NumberInputProps | Properties for the NumberInput component | |
OptionType | OptionType for react-select 2.0 and above. | Beta |
PointProps | Describes 2d points. | Deprecated |
PopupContextMenuProps | Properties for PopupContextMenu component | |
PopupProps | Properties for the Popup component | |
ProcessSettingsContainerCloseEventArgs | Arguments of onProcessSettingsContainerClose event. | |
ProcessSettingsTabActivationEventArgs | Arguments of onProcessSettingsTabActivation event. | |
ProgressBarProps | Properties for ProgressBar component | Beta |
ProgressSpinnerProps | Properties for ProgressSpinner component | Beta |
RadialButtonProps | Properties for RadialButton component | |
RadialMenuProps | Properties for RadialMenu | |
RadioProps | Properties for Radio component | Deprecated |
RatioChangeResult | Results returned by onRatioChanged callback for determining new ratio and whether the ratio was updated. | |
Describes a React based message | ||
RectangleProps | Describes 2d bounds. | |
RenderPropsArgs | Prop the ElementResizeObserver sends to the render function. | |
SearchBoxProps | Properties for SearchBox component | |
SelectOption | Properties for a Select option | Deprecated |
SelectProps | Properties for Select component | Deprecated |
SettingsContainerProps | ||
SettingsProvidersChangedEventArgs | Arguments of onSettingsProvidersChanged event. | |
SettingsTabEntry | Interface used to populate a tab entry in the SettingContainer control | |
SettingsTabsProvider | Setting Provider interface. | |
SizeProps | Describes 2d dimensions. | |
SliderProps | Properties for Slider component | |
SpinnerProps | Properties for Spinner component | Deprecated |
SplitButtonProps | Properties for SplitButton component | Deprecated |
StyledTextProps | Properties for StyledText component | |
SvgPathProps | Properties of SvgPath component. | |
SvgSpriteProps | Properties of SvgSprite component. | |
TabLabel | TabLabel provides ability to define label, icon, and tooltip for a tab entry. | |
TabsProps | Properties for the HorizontalTabs and VerticalTabs components | |
TextareaProps | Properties for Textarea component | Deprecated |
TextProps | Properties for various text components | |
TileProps | Properties for the Tile component | Beta |
ToggleProps | Properties for Toggle component | Deprecated |
TooltipProps | Properties for the Tooltip component | Beta |
TreeBranchProps | Properties for TreeBranch React component | |
TreeNodePlaceholderProps | Properties for the TreeNodePlaceholder React component | |
TreeNodeProps | Properties for the TreeNode React component | |
TreeProps | Properties for the Tree presentational React component | |
UiStateStorage | Interface for getting, saving and deleting settings. | |
UiStateStorageResult | Interface for result of accessing UI state setting in UiStateStorage. | |
UnderlinedButtonProps | Properties for the UnderlinedButton React component | |
WebFontIconProps | Properties for the WebFontIcon React component | |
WithIsPressedProps | Properties for withIsPressed React higher-order component | |
WithOnOutsideClickProps | Properties for withOnOutsideClick React higher-order component | |
WithTimeoutProps | Properties for withTimeout React higher-order component |
Type Aliases
Name | Description | |
---|---|---|
AsyncGetAutoSuggestDataFunc | ||
ExecuteHandler | ||
FieldEditor | The available editors for the fields in a Form. | |
GetAutoSuggestDataFunc | ||
IconSpec | Prototype for an IconSpec which can be a string, ReactNode or ConditionalStringValue. | |
Types for message | ||
NodeCheckboxRenderer | ||
NodeCheckboxRenderProps | Props for node Checkbox renderer | |
Omit | Used to omit properties in a given interface | |
OmitChildrenProp | Omit children property from T. | |
OptionsType | OptionsType to match label/value pair OptionType | Beta |
OutsideClickEvent | ||
RadialSizeType | Type for ProgressRadialProps.size | |
StepFunctionProp | Step function prototype for NumberInput component | |
ThemedSelectProps | ThemedSelectProps to control specific features of ThemedSelect | Beta |
TooltipPlacement | Available tooltip placements. | Beta |
Last Updated: 30 November, 2023