LabeledThemedSelectProps Interface
Beta @deprecated in 3.0. Use LabeledSelect component from @itwin/itwinui-react
Properties for LabeledThemedSelect components
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
formatOptionLabel(optionType: OptionType, formatLabelMeta: FormatOptionLabelMeta): ReactNode Optional | ThemedSelectProps | |
isOptionDisabled(option: OptionType, options: OptionsType): boolean Optional | ThemedSelectProps | |
ThemedSelectProps | ||
onChange(value: ValueType<OptionType>, action: ActionMeta<OptionType>): void Optional | ThemedSelectProps | |
onInputChange(newValue: string, actionMeta?: InputActionMeta): void Optional | ThemedSelectProps | |
onMenuClose(): void Optional | ThemedSelectProps | |
onMenuOpen(): void Optional | ThemedSelectProps | |
onMenuScrollToBottom(e: SyntheticEvent<HTMLElement, Event>): void Optional | ThemedSelectProps | |
onMenuScrollToTop(e: SyntheticEvent<HTMLElement, Event>): void Optional | ThemedSelectProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
aria-label | undefined | string | ThemedSelectProps | |
aria-labelledby | undefined | string | ThemedSelectProps | |
autoFocus | undefined | boolean | ThemedSelectProps | |
backspaceRemovesValue | undefined | boolean | ThemedSelectProps | |
blurInputOnSelect | undefined | boolean | ThemedSelectProps | |
captureMenuScroll | undefined | boolean | ThemedSelectProps | |
className | undefined | string | ThemedSelectProps | |
closeMenuOnScroll | boolean | EventListener | ThemedSelectProps | |
closeMenuOnSelect | undefined | boolean | ThemedSelectProps | |
components | undefined | Partial<SelectComponents<OptionType>> | ThemedSelectProps | |
controlShouldRenderValue | undefined | boolean | ThemedSelectProps | |
defaultMenuIsOpen | undefined | boolean | ThemedSelectProps | |
defaultValue | undefined | ValueType<OptionType> | ThemedSelectProps | |
divRef | undefined | Ref<HTMLDivElement> | ThemedSelectProps | Provides ability to return reference to the outer HTMLDivElement |
escapeClearsValue | undefined | boolean | ThemedSelectProps | |
filterOption | | (option: OptionType, rawInput: string) => boolean | ThemedSelectProps | |
formatGroupLabel | undefined | (group: GroupType<any>) => ReactNode | ThemedSelectProps | |
getOptionLabel | undefined | (option: any) => string | ThemedSelectProps | |
getOptionValue | undefined | (option: any) => string | ThemedSelectProps | |
hideSelectedOptions | undefined | boolean | ThemedSelectProps | |
id | undefined | string | ThemedSelectProps | |
inputClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the checkbox input element |
inputId | undefined | string | ThemedSelectProps | |
inputStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the checkbox input element |
inputValue | undefined | string | ThemedSelectProps | |
instanceId | string | number | ThemedSelectProps | |
isClearable | undefined | boolean | ThemedSelectProps | |
isDisabled | undefined | boolean | ThemedSelectProps | |
isLoading | undefined | boolean | ThemedSelectProps | |
isMenuFixed | undefined | boolean | ThemedSelectProps | |
isMulti | undefined | boolean | ThemedSelectProps | |
isRtl | undefined | boolean | ThemedSelectProps | |
isSearchable | undefined | boolean | ThemedSelectProps | |
label | undefined | string | LabeledComponentProps | Text that will be shown next to or above the input. |
labelClassName | undefined | string | LabeledComponentProps | Custom CSS class name for the label |
labelStyle | undefined | CSSProperties | LabeledComponentProps | Custom CSS Style for the label |
maxMenuHeight | undefined | number | ThemedSelectProps | |
menuIsOpen | undefined | boolean | ThemedSelectProps | |
menuShouldBlockScroll | undefined | boolean | ThemedSelectProps | |
menuShouldScrollIntoView | undefined | boolean | ThemedSelectProps | |
undefined | string | MessagedComponentProps | Optional text shown below the input. | |
undefined | string | MessagedComponentProps | Custom CSS class name for the message | |
undefined | CSSProperties | MessagedComponentProps | Custom CSS Style for the message | |
minMenuHeight | undefined | number | ThemedSelectProps | |
name | undefined | string | ThemedSelectProps | |
onBlur | undefined | FocusEventHandler | ThemedSelectProps | |
onFocus | undefined | FocusEventHandler | ThemedSelectProps | |
onKeyDown | undefined | KeyboardEventHandler | ThemedSelectProps | |
openMenuOnClick | undefined | boolean | ThemedSelectProps | |
openMenuOnFocus | undefined | boolean | ThemedSelectProps | |
options | OptionsType | ThemedSelectProps | |
pageSize | undefined | number | ThemedSelectProps | |
placeholder | undefined | string | ThemedSelectProps | |
ref | undefined | Ref<StateManager<{ T }, default<{ T }>>> | ThemedSelectProps | Provides ability to return reference to the ThemedSelect |
status | undefined | InputStatus | LabeledComponentProps | Input status like: "Success", "Warning" or "Error" |
styles | undefined | CSSProperties | ThemedSelectProps | |
tabIndex | undefined | string | ThemedSelectProps | |
tabSelectsValue | undefined | boolean | ThemedSelectProps | |
value | undefined | ValueType<OptionType> | ThemedSelectProps |
Defined in
Last Updated: 30 November, 2023