TabLabel Interface
TabLabel provides ability to define label, icon, and tooltip for a tab entry. The tooltip can be defined as JSX|Element to support react-tooltip component or a string that will be use to set the title property.
Properties
Name | Type | Description | |
---|---|---|---|
disabled | undefined | boolean | ||
icon | string | Element | ||
label | string | ||
subLabel | undefined | string | ||
tabId | string | ||
tooltip | string | Element | tooltip allows React.JSX.Element to support styled tooltips like react-tooltip. |
Defined in
Last Updated: 30 November, 2023