components-react
Classes
Name | Description | |
---|---|---|
AbstractTreeNodeLoader | Abstract node loader implementation which loads nodes into provided model source. | |
AbstractTreeNodeLoaderWithProvider | Abstract node loader with tree data provider which loads nodes into provided model source. | |
ActionButtonList | ActionButtonList React component. | |
ArrayPropertyValueRenderer | Default Array Property Renderer | |
BasePointTypeConverter | Point type converter. | |
BasicPropertyEditor | Basic Property Editor registered for the "text" and "string" type names. | |
BooleanEditor | BooleanEditor React component that is a property editor with checkbox input | |
BooleanPropertyEditor | Boolean Property Editor registered for the "bool" and "boolean" type names. | |
BooleanTypeConverter | Boolean Type Converter. | |
Breadcrumb | Breadcrumb navigation component, with two discrete modes: text mode and dropdown mode. | Beta |
BreadcrumbDetails | A Table containing all children of tree node specified in path. | Beta |
BreadcrumbNode | Default BreadcrumbNode component | Beta |
BreadcrumbPath | Breadcrumb Path class. | Beta |
BreadcrumbTreeUtils | Utility class for tree searching and manipulation in the Breadcrumb component. | Beta |
BreadcrumbUpdateEvent | BreadcrumbChangeEvent Event class. | Beta |
ColumnDragLayer | React component used to portray a column being dragged during Table column reordering. | Deprecated |
CompositePropertyDataFilterer | Composite PropertyData filter which can join two filters using logic operators | |
CompositeTypeConverter | Composite type converter | |
DataControllerBase | DataControllerBase is the base class for all Data Controllers. | |
DateTimeTypeConverter | Date Time Type Converter. | |
DateTimeTypeConverterBase | DateTime Type Converter. | |
DisplayValuePropertyDataFilterer | Property data filterer which matches on Primitive Property Record display value text. | |
DistinctValueCollection | A set of distinct values for a column. | Deprecated |
DoublePropertyValueRenderer | Default Double Property Renderer | |
EditorContainer | EditorContainer React component used by the Table, Tree and PropertyGrid for cell editing. | |
EnumButtonGroupEditor | EnumButtonGroupEditor React component that is a property editor with select input | |
EnumEditor | EnumEditor React component that is a property editor with select input | |
EnumPropertyButtonGroupEditor | Enum Property Button Group Editor registered for the "enum" type name and the "enum-buttongroup" editor name. | |
EnumPropertyEditor | Enum Property Button Group Editor registered for the "enum" type name. | |
EnumTypeConverter | Enum Type Converter. | |
FavoritePropertiesRenderer | Renderer for Favorite Property List | |
FilterDescriptorCollection | Collection of filter descriptors. | Deprecated |
FilterDescriptorCollectionBase | Collection of filter descriptors. | Deprecated |
FilteringInput | A helper component for filtering trees and stepping through results | |
FilteringPropertyDataProvider | IPropertyDataProvider implementation which filters wrapped provider PropertyData using passed IPropertyDataFilterer. | |
FloatTypeConverter | Float Type Converter. | |
HexadecimalTypeConverter | Hexadecimal Type Converter. | |
HighlightingEngine | Tree highlighting engine | |
ImageCheckBoxEditor | ImageCheckBoxEditor | |
ImageCheckBoxPropertyEditor | ImageCheckBox Property Editor registered for the "bool" and "boolean" type names. | |
IntTypeConverter | Int Type Converter. | |
LabelPropertyDataFilterer | PropertyData filter which matches on any record type label and includes descendant nodes on match | |
MergedPropertyValueRenderer | Default Merged Property Renderer | |
MutableCategorizedArrayProperty | Mutable wrapper object for PropertyRecord with array valueFormat which provides methods for working with and managing record children hierarchies. | |
MutableCategorizedPrimitiveProperty | Mutable wrapper object for PropertyRecord with primitive valueFormat. | |
MutableCategorizedProperty | Base class for all Mutable CategorizedProperties | |
MutableCategorizedStructProperty | Mutable wrapper object for PropertyRecord with struct valueFormat which provides methods for working with and managing record children hierarchies. | |
MutableFlatPropertyGridItem | Base class for all FlatPropertyGrid items | |
MutableGridCategory | Mutable wrapper object for PropertyCategory which provides methods for working with and managing category and record children hierarchies | |
MutableGridItemFactory | Implementation of IMutableGridItemFactory for creating MutableGridItem objects. | |
MutablePropertyGridModel | Implementation of PropertyGridModel for working with and converting PropertyData to mutable FlatGridItems | |
MutableTreeModel | Mutable tree model which holds nodes and allows adding or removing them. | |
NavigationPropertyTypeConverter | Navigation property type converter. | |
NavigationPropertyValueRenderer | Default Navigation Property Renderer | |
NonPrimitivePropertyLabelRenderer | A React component that renders a non-primitive property label. | |
NonPrimitivePropertyRenderer | React Component that renders struct and array properties | |
NumericInputEditor | NumericInputEditor React component that is a property editor with numeric input & up/down buttons | |
NumericInputPropertyEditor | Numeric Input Property Editor registered for the "number" type name and "numeric-input" editor name. | |
NumericTypeConverterBase | Base Numeric Type Converter. | |
OperatorValueFilterDescriptorCollection | Collection of OperatorValue filter descriptors. | Deprecated |
PagedTreeNodeLoader | Default paged tree node loader with TreeDataProvider implementation. |
|
Point2dTypeConverter | Point2d type converter. | |
Point3dTypeConverter | Point3d type converter. | |
PrimitivePropertyLabelRenderer | A React component that renders a primitive property label | |
PrimitivePropertyRenderer | React Component that renders primitive properties | |
PrimitivePropertyValueRenderer | Default Primitive Property Renderer | |
PropertyCategoryBlock | PropertyCategoryBlock React component | |
PropertyCategoryDataFiltererBase | An abstract implementation of IPropertyDataFilterer that can be used as base for all | |
PropertyCategoryLabelFilterer | PropertyData filterer which matches on PropertyCategory's label. | |
PropertyCategoryRendererManager | Keeps a record of currently registered property category renderers and determines which renderers get invoked for | |
PropertyDataChangeEvent | An event broadcasted on property data changes | |
PropertyDataFiltererBase | An abstract implementation of IPropertyDataFilterer to share common behavior between different implementations. | |
PropertyEditorBase | PropertyEditor is the base class for all property editors. | |
PropertyEditorManager | Manages Property Editors. | |
PropertyFilterChangeEvent | An event broadcasted when property filter changes | |
PropertyGrid | PropertyGrid React component. | Deprecated |
PropertyGridEventHandler | Handles events and changes on PropertyGridModel data. | |
PropertyGridModelChangeEvent | An event broadcasted on property grid model changes | |
PropertyGridModelSource | Controls property grid model. | |
PropertyList | A React component that renders multiple properties within a category as a list. | |
PropertyRecordDataFiltererBase | An abstract implementation of IPropertyDataFilterer that can be used as base for all | |
PropertyRenderer | A React component that renders properties | |
PropertyValueRendererManager | Default implementation of property value renderer manager | |
PropertyView | A React component that renders property as label/value pair | |
ResultSelector | Component for stepping through results/entries | |
ShortDateTypeConverter | Short Date Type Converter. | |
ShowHideDialog | Dialog Component used to toggle show/hide table columns, given through items prop, through a list of checkboxes. | |
ShowHideMenu | ContextMenu Component used to toggle show/hide items, given through items prop, through a list of checkboxes. | |
SimplePropertyDataProvider | Implementation of [IPropertyDataProvider] that uses an associative array. | |
SimpleTableDataProvider | A Table Data Provider using an array of items. | Deprecated |
SimpleTreeDataProvider | A tree data provider using SimpleTreeDataProviderHierarchy. | |
SliderEditor | SliderEditor React component that is a property editor with numeric input & up/down buttons | |
SliderPropertyEditor | Slider Property Editor registered for the "number" type name and "slider" editor name. | |
SparseArray | Structure for sparse array value storage. | |
StringTypeConverter | String Type Converter. | |
StructPropertyValueRenderer | Default Struct Property Renderer | |
Table | Table React component that displays rows and columns in a grid along with a header | Deprecated |
TableArrayValueRenderer | A react component which renders array property value as a button with text | |
TableCell | A React component that renders a table cell | Deprecated |
TableCellContent | A React component that renders table cell content | Deprecated |
TableDataChangeEvent | An event broadcasted on table data changes | Deprecated |
TableIconCellContent | A React component that renders table cell content as a Bentley icon | Deprecated |
TableNonPrimitiveValueRenderer | A React component that renders non primitive values as a button with text. | |
TableStructValueRenderer | A react component which renders struct property value as a button with text | |
TextareaEditor | TextareaEditor React component that is a property editor with text input | |
TextareaPropertyEditor | Textarea Property Editor registered for the "text" and "string" type names and "multi-line" editor name. | |
TextEditor | TextEditor React component that is a property editor with text input | |
ThemedEnumEditor | EnumEditor React component that is a property editor with select input | Beta |
ThemedEnumPropertyEditor | Enum Property Button Group Editor registered for the "enum" type name. | Beta |
ToggleEditor | ToggleEditor React component that is a property editor with checkbox input | |
TogglePropertyEditor | Toggle Property Editor registered for the "bool" and "boolean" type names and "toggle" editor name. | |
TreeEventHandler | Default tree event handler. | |
TreeImageLoader | Default image loader for the tree | |
TreeModelSource | Controls tree model. | |
TreeNodeLoader | Default tree node loader with TreeDataProvider implementation. |
|
TreeRenderer | Default tree rendering component. | |
TypeConverter | Type Converter base class. | |
TypeConverterManager | Manages Type Converters. | |
UiComponents | Manages the localization service for the components-react package. | |
UrlPropertyValueRenderer | URL property value renderer that renders the whole value as a URL without matching it | |
VirtualizedPropertyGrid | VirtualizedPropertyGrid React component. |
Constants
Name | Description | |
---|---|---|
DEFAULT_LINKS_HANDLER | Default link handler used for handling records, | |
ItemStyleProvider | Style provider for stylable items like CellItem and TreeNodeItem | |
TableRowStyleProvider | Style provider for table rows | |
ToolbarButtonItem | Toolbar item component. | |
ToolbarPopupAutoHideContext | Context used by Toolbar items to know if popup panel should be hidden - via AutoHide. | |
ToolbarPopupContext | Context used by Toolbar items in popups to close the popup panel. | |
TreeNodeRenderer | Default component for rendering tree node. |
Enumerations
Name | Description | |
---|---|---|
BreadcrumbMode | Enum for Breadcrumb Mode | Beta |
CompositeFilterType | Logical operator for composite filterer. | |
Direction | Available directions. | |
DropEffects | Enum for different DropEffects. | Beta |
DropStatus | Enum for status of current drag/drop item | Beta |
FilterCompositionLogicalOperator | Logical operator used for filter descriptor composition | Deprecated |
FilteredType | Enumeration of possible component filtered types | |
FilteringInputStatus | Enumeration of possible component contexts | |
FilterOperator | Operator used in FilterDescriptor | Deprecated |
FilterRenderer | Filter Renderer for a Table column | Deprecated |
FlatGridItemType | Types of FlatGridItems for differentiating what property FlatGridItem is wrapping. | |
PropertyContainerType | Types of property containers | |
PropertyFilterRuleGroupOperator | Logical operator for joining rules. | Beta |
PropertyFilterRuleOperator | Operators for comparing property value in rule. | Beta |
SelectionMode | Selection modes for Table and Tree row selection | |
SelectionModeFlags | Selection mode flags for Table and Tree row selection | |
TableSelectionTarget | Specifies table selection target. | Deprecated |
ToolbarOpacitySetting | Enumeration of Toolbar Opacity setting. | |
ToolbarPanelAlignment | Available alignment modes of ToolbarWithOverflow panels. |
Global Functions
Name | Description | |
---|---|---|
adjustDateToTimezone | Adjust a Date object to show time in one time zone as if it is in the local time zone. | |
BeDragDropContext | Context component for DragDrop API. | Beta |
computeVisibleNodes | Generates flat list of visible nodes in the tree model. | |
ControlledSelectableContent | A fully-controlled component that accepts a list of child components with ids and labels and | |
ControlledTree | React tree component which rendering is fully controlled from outside. | |
from | Helper method that creates an Observable from Iterable or Promise. | |
getPropertyFilterOperatorLabel | Function that returns display label for rule operator. | Beta |
getPropertyFilterOperators | Function that returns set of available operator based on property type. | Beta |
hasChildren | Determines whether node has children | |
hasSelectionModeFlag | Determines if a SelectionMode is active | |
HighlightedText | Highlighted text | |
isPropertyFilterRuleGroup | Function that checks if supplied filter is rule group. | Beta |
isTreeDataProviderInterface | Checks if TreeDataProvider is an ITreeDataProvider | |
isTreeDataProviderMethod | Checks if TreeDataProvider is a TreeDataProviderMethod | |
isTreeDataProviderPromise | Checks if TreeDataProvider is a TreeDataProviderPromise | |
isTreeDataProviderRaw | Checks if TreeDataProvider is a TreeDataProviderRaw | |
isTreeModelNode | Checks if object is TreeModelNode | |
isTreeModelNodePlaceholder | Checks if object is TreeModelNodePlaceholder | |
isTreeModelRootNode | Checks if object is TreeModelRootNode | |
isUnaryPropertyFilterOperator | Function that checks if supplied operator is unary. | Beta |
LinksRenderer | React component for rendering string with links. | |
matchLinks | Returns a list of links from a text | |
ParsedInput | Generic Input component that requires formatting and parsing functions to be passed in as props. | |
PopupItem | Popup toolbar item that displays a panel | |
PopupItemWithDrag | Expandable Group button Item | |
PropertyFilterBuilder | Component for building complex filters. | Beta |
renderLinks | Renders anchor tag by wrapping or splitting provided text | |
SelectableContent | An uncontrolled component that accepts a list of child components with ids and labels and | |
toDateString | Format a date in a display string, optionally converting to time zone, if specified by timeZoneOffset | |
Toolbar | Component that displays tool settings as a bar across the top of the content view. | |
ToolbarWithOverflow | Component that displays tool settings as a bar across the top of the content view. | |
toTimeString | Format the time included in a date, optionally converting to time zone, if specified | |
TreeNodeEditor | React component for displaying tree node editor. | |
useAsyncValue | Custom hook for working with possibly async values. | |
useDebouncedAsyncValue | Custom hook for working with promise values. | Beta |
useDragInteraction | Hook used on expandable item that require drag or long press to open | |
usePagedTreeNodeLoader | Custom hook which creates a paging nodes' loader using the supplied data provider and model source. | |
usePropertyData | Custom hook that gets PropertyData from given IPropertyDataProvider and subscribes to further data changes. | |
usePropertyGridEventHandler | Custom hook that creates memoized version of PropertyGridEventHandler that modifies given modelSource | |
usePropertyGridModel | Custom hook that automatically listens and retrieves latest model from model source | |
usePropertyGridModelSource | Custom hook that creates a PropertyGridModelSource and subscribes it to data updates from the data provider. | |
useToolbarPopupAutoHideContext | React hook used to retrieve the ToolbarPopupAutoHideContext. | |
useToolbarPopupContext | React hook used to retrieve the ToolbarPopupContext. | |
useTreeEventsHandler | Custom hook which creates and takes care of disposing a TreeEventsHandler. | |
useTreeModel | React hook that returns an immutable TreeModel whenever it changes in the given |
|
useTreeModelSource | Custom hook which creates a TreeModelSource . |
|
useTreeNodeLoader | Custom hook which creates a nodes' loader using the supplied data provider and model source. | |
VirtualizedPropertyGridWithDataProvider | VirtualizedPropertyGrid React Component which takes dataProvider and | |
withContextStyle | Wraps a React component with a span element with a given style attribute | |
withDragSource | HOC (Higher-Order Component) that transforms wrapped component into a DragSource. | Beta |
withDropTarget | HOC (Higher-Order Component) that transforms wrapped component into a DropTarget. | Beta |
withLinks | If record has links, wraps stringValue in them, otherwise returns unchanged stringValue |
Interfaces
Name | Description | |
---|---|---|
ActionButtonListProps | Properties of ActionButtonList React component | |
ActionButtonRendererProps | Properties of ActionButtonRenderer | |
ActiveMatchInfo | Properties for identifying an active highlight on a node in a tree. | |
Asynchronous Error Message returned as part of AsyncValueProcessingResult | ||
AsyncValueProcessingResult | Asynchronous Value Process Result | |
BreadcrumbDetailsProps | Properties for the BreadcrumbDetails component | Beta |
BreadcrumbNodeProps | Properties for BreadcrumbNode component | Beta |
BreadcrumbProps | Properties for Breadcrumb component | Beta |
BreadcrumbUpdateEventArgs | BreadcrumbChangeEvent Event Args class. | Beta |
CategorizedPropertyItem | Data structure which describes methods and properties present on immutable CategorizedPropertyItem objects | |
CategoryRecordsDict | Category name to PropertyRecord[] key pair interface used to describe which records belong to which category. | |
CellItem | Cell definition provided to Table. | Deprecated |
CellProps | Properties for a Table cell | Deprecated |
CheckBoxInfo | Immutable data structure that describes checkbox info. | |
CheckboxStateChange | Data structure that describes checkbox state change. | |
ColumnDescription | Column definition provided to Table. | Deprecated |
ColumnFilterDescriptor | Represents a column filter descriptor associated with a specific column. | Deprecated |
CommonPropertyGridProps | Common Property Grid Props to be used by Property Grid Variants | |
CompletionObserver | CompletionObserver interface compatible with rxjs | |
CompositeFilterDescriptor | Represents a composite filtering abstraction which has a collection of | Deprecated |
CompositeFilterDescriptorCollection | Collection of FilterDescriptor objects composed together by a logical operator. | Deprecated |
ControlledSelectableContentProps | ControlledSelectableContent component properties | |
ControlledTreeProps | Properties for ControlledTree | |
CustomToolbarItem | Describes the data needed to insert a custom React button into an ToolbarWithOverflow. |
|
DataController | DataControllers can be implemented per typename to validate and commit values. | |
DateFormatOptions | Define formatting options for use when component are generating a formatted date string calling Date.toLocaleTimeString() . |
|
DelayLoadedTreeNodeItem | A TreeNodeItem for delay-loaded trees | |
DistinctValuesFilterDescriptor | Represents the distinct filter descriptor of a column filter descriptor. | Deprecated |
DragDropArguments | Base DragDropArguments interface, used by both DragSourceArguments and DragTargetArguments. | Beta |
DragLayerProps | Properties for DragLayer components | Beta |
DragSourceArguments | Interface for arguments supplied to DragSource callbacks, including onDragSourceBegin, and onDragSourceEnd, as well as to the DragLayers as a prop. | Beta |
DragSourceProps | Properties and callbacks for the withDragSource Higher-Order Component. | Beta |
DropTargetArguments | Interface for arguments supplied to DropTarget callbacks, including onDropTargetOver, onDropTargetDrop, and canDropTargetDrop. | Beta |
DropTargetProps | Properties and callbacks for the withDragSource Higher-Order Component. | Beta |
EditableTreeDataProvider | EditableTreeDataProvider provides cell editing processing for the Tree. | |
EditorContainerProps | EditorContainer React component properties | |
ErrorObserver | ErrorObserver interface compatible with rxjs | |
FieldFilterDescriptor | Represents the field filter descriptor of a column filter descriptor. | Deprecated |
FilterableColumn | Represents a column that is filterable. | Deprecated |
FilterableTable | FilterableTable contains the properties and methods provided by a filterable Table. | Deprecated |
FilterDescriptor | A filtering abstraction that knows how to create predicate filtering expression. | Deprecated |
FilteredPropertyData | Data returned by FilteringPropertyDataProvider | |
FilteringInputProps | FilteringInput React Component properties | |
FlatGridItemBase | Base immutable data structure defining common methods and properties for categories and categorized properties | |
GridCategoryItem | Data structure which describes methods and properties present on immutable GridCategoryItem | |
HighlightableTreeNodeProps | Properties for a highlightable TreeNode | |
HighlightableTreeProps | Properties for highlighting nodes in a tree. | |
HighlightedTextProps | Properties of HighlightedText | |
HighlightInfo | Item highlight info used for identification of a specific highlight in an item | |
HighlightingComponentProps | Properties used for highlighting parts in item by given text and actively highlighting one highlight in a distinct item specified in activeHighlight |
|
IImageLoader | Interface for an image loader. | |
ImmediatelyLoadedTreeNodeItem | A TreeNodeItem for immediately loaded trees | |
IMutableCategorizedPropertyItem | Data structure which describes methods and properties to be held by Mutable CategorizedPropertyItems | |
IMutableFlatPropertyGridItem | Base mutable data structure defining common methods and properties for both CategorizedProperties and GridCategoryItems | |
IMutableGridCategoryItem | Data structure which describes methods and properties to be held by Mutable GridCategoryItems | |
IMutableGridItemFactory | IMutableGridItemFactory interface for creating MutableGridItem objects | |
IMutablePropertyGridModel | PropertyGridModel interface for working with mutable FlatGridItems | |
IPropertyDataFilterer | An interface for a filterer that filters PropertyData based on content of PropertyRecord | |
IPropertyDataProvider | An interface for property data provider which returns | |
IPropertyGridEventHandler | Handles events and changes on PropertyGridModel data. | |
IPropertyGridModel | PropertyGridModel interface for working with immutable FlatGridItems | |
IPropertyGridModelSource | ||
IPropertyValueRenderer | Custom property value renderer interface | |
ItemColorOverrides | Color overrides for styled item | |
ItemStyle | Style properties for styled item like CellItem and TreeNodeItem | |
ITreeDataProvider | Interface for a tree data provider class | |
ITreeImageLoader | Interface for a tree image loader | |
ITreeNodeLoader | Tree node loader which is used to load tree nodes. | |
ITreeNodeLoaderWithProvider | Tree node loader which uses TreeDataProvider to load nodes. |
|
LessGreaterOperatorProcessor | Operators for Numeric types, DateTime, TimeSpan, or any type that supports these comparisons | |
LinksRendererProps | Properties for LinksRenderer component. | |
LoadedBinaryImage | Image data for raw images | |
LoadedImage | Image data for string based images | |
LoadedNodeHierarchy | Data structure that describes hierarchy loaded for parent node. | |
LoadedNodeHierarchyItem | Data structure that describes one loaded hierarchy item. | |
MutableCheckBoxInfo | Mutable data structure that describes checkbox info. | |
MutableTableDataProvider | MutableTableDataProvider provides mutation methods for data in the Table. | Deprecated |
MutableTreeDataProvider | MutableTreeDataProvider provides manipulation processing for the Tree. | Beta |
MutableTreeModelNode | Mutable data structure that describes tree node. | |
NextObserver | NextObserver interface compatible with rxjs | |
NonPrimitivePropertyLabelRendererProps | Properties for the NonPrimitivePropertyLabelRenderer React component | |
NonPrimitivePropertyRendererProps | Properties of NonPrimitivePropertyRenderer React component | |
NullableOperatorProcessor | Operators for all filterable null-able types | |
Observable | Observable interface compatible with rxjs | |
OperatorProcessor | Operators for all filterable types | |
OperatorValueFilterDescriptor | An abstraction for all filter descriptors that have an operator and a value | Deprecated |
PageOptions | Paging options. | |
ParsedInputProps | Props for ParsedInput control | |
PopupItemProps | Properties of PopupItem component. | |
PopupItemWithDragProps | Properties of PopupItem component. | |
PrimitivePropertyLabelRendererProps | Properties of a PrimitivePropertyLabelRenderer React component | |
PrimitiveRendererProps | Properties of PrimitivePropertyRenderer React component | |
PropertyCategory | Contains metadata about a group of Properties. | |
PropertyCategoryBlockProps | Properties for the PropertyCategoryBlock React component | |
PropertyCategoryRendererProps | Props that property category renderer receives. | |
PropertyData | Interface for property data provided to the PropertyGrid React component. | |
PropertyDataFilterResult | Data structure for storing IPropertyDataFilterer matching results | |
PropertyDialogState | State of the Dialog component in a container which renders properties | |
PropertyEditingArgs | Arguments for the Property Editing event callback | |
PropertyEditorProps | Properties for a property editor component | |
PropertyFilterBuilderProps | Props for PropertyFilterBuilder component. | Beta |
PropertyFilterRule | Data structure that describes single filter rule. | Beta |
PropertyFilterRuleGroup | Data structure that describes group of filter rules. | Beta |
PropertyGridCategory | Property Category in the PropertyGrid state | Deprecated |
PropertyGridContextMenuArgs | Arguments for PropertyGridProps.onPropertyContextMenu callback |
|
PropertyGridProps | Properties for PropertyGrid React component | Deprecated |
PropertyLabelRendererProps | Base properties for a property label renderer | |
PropertyListProps | Properties of PropertyList React component | |
PropertyPopupState | State of the Popup component in a container which renders properties | |
PropertyRendererProps | Properties of PropertyRenderer React component | |
PropertyUpdatedArgs | Arguments for the Property Updated event callback | |
PropertyValueRendererContext | Additional parameters to the renderer | |
PropertyViewProps | Properties of PropertyView React component | |
ReactDataGridColumn | ReactDataGrid.Column with additional properties | Deprecated |
RenderedItemsRange | Data structure that describes range of rendered items in the tree. | |
ResultSelectorProps | ResultSelector React Component properties | |
RowItem | Row definition provided to Table. | Deprecated |
RowProps | Properties for a Table row | Deprecated |
SelectableContentDefinition | A definition for content displayed in ControlledSelectableContent and | |
SelectableContentProps | SelectableContent component properties | |
SharedRendererProps | Properties shared by all renderers and PropertyView | |
SharedTableNonPrimitiveValueRendererProps | Shared properties between table non-primitive value renderers | |
ShowHideDialogProps | Properties for the ShowHideDialog component used in the Table to show/hide columns. | |
ShowHideItem | Interface for ShowHide items used to show/hide Table columns. | |
ShowHideMenuProps | Properties for the ShowHideMenu component | |
SortComparer | Sort compare method for types that support sorting | |
StringOperatorProcessor | Operators for string types | |
Subscribable | Subscribable interface compatible with rxjs | |
Subscription | Subscription interface compatible with rxjs | |
TableCellContentProps | Properties of the TableCellContent React component | Deprecated |
TableCellContextMenuArgs | Arguments for TableProps.onCellContextMenu callback |
Deprecated |
TableCellEditorState | Cell/Property Editor state | Deprecated |
TableCellProps | Properties of the TableCell React component | Deprecated |
TableCellUpdatedArgs | Cell/Property Updated Args | Deprecated |
TableDataProvider | TableDataProvider provides data to the Table. | Deprecated |
TableDistinctValue | Distinct Value for Table filtering purposes | Deprecated |
TableIconCellContentProps | Properties for the TableIconCellContent React component | Deprecated |
TableNonPrimitiveValueRendererProps | Properties for TableNonPrimitiveValueRenderer React component | |
TableProps | Properties for the Table React component | Deprecated |
TableSpecificValueRendererProps | Properties for TableArrayValueRenderer and TableStructValueRenderer React component | |
ThemedEnumEditorProps | Properties for ThemedEnumEditor component | Beta |
ToolbarButtonItemProps | Properties of ToolbarButtonItem component. | |
ToolbarPopupContextProps | ||
ToolbarProps | Properties of Toolbar component. | |
ToolbarWithOverflowProps | Properties of ToolbarWithOverflow component. | |
TreeActions | Tree actions that can be performed on tree. | |
TreeCheckboxStateChangeEventArgs | Data structure that describes tree checkbox state change event payload. | |
TreeEditingParams | Params used for tree node editing. | |
TreeEventHandlerParams | Data structure that describes tree event handler params. | |
TreeEvents | Tree events that can occur while interacting with tree. | |
TreeModel | Data structure that describes tree model. | |
TreeModelChanges | Data structure that describes changes which happened to the tree model | |
TreeModelNode | Immutable data structure that describes tree node. | |
TreeModelNodeEditingInfo | Data structure that holds callbacks used for tree node editing. | |
TreeModelNodeInput | Data structure that describes input used to create tree node. | |
TreeModelNodePlaceholder | Data structure that describes tree node placeholder. | |
TreeModelRootNode | Data structure that describes tree root node. | |
TreeNodeEditorProps | Properties for TreeNodeEditor component. | |
TreeNodeEventArgs | Data structure that describes tree node event payload. | |
TreeNodeItem | A node item which can be displayed in a tree. | |
TreeNodeLoadResult | Data structure that describes node load result | |
TreeNodeRendererProps | Properties for TreeNodeRenderer. | |
TreeRendererAttributes | Attributes found on TreeRenderer component | |
TreeRendererProps | Properties for TreeRenderer component. | |
TreeSelectionChange | Data structure that describes tree selection change. | |
TreeSelectionModificationEventArgs | Data structure that describes tree selection modification event payload. | |
TreeSelectionReplacementEventArgs | Data structure that describes tree selection replacement event payload. | |
TypeEditor | Interface implemented by React based type editors | |
Unsubscribable | Unsubscribable interface compatible with rxjs | |
VirtualizedPropertyGridContext | Context of the surrounding VirtualizedPropertyGrid component. | |
VirtualizedPropertyGridProps | Properties for VirtualizedPropertyGrid React component | |
VirtualizedPropertyGridWithDataProviderProps | Properties for VirtualizedPropertyGridWithDataProvider React component | |
VisibleTreeNodes | Data structure that describes set of visible tree nodes as a flat list. | |
WithDragSourceProps | React properties for withDragSource Higher-Order Component | Beta |
WithDropTargetProps | React properties for withDropTarget Higher-Order Component | Beta |
Namespaces
Name | Description | |
---|---|---|
ConvertedPrimitives | Converted Primitives namespace |
Type Aliases
Name | Description | |
---|---|---|
ActionButtonRenderer | ||
CategorizedPropertyTypes | Type which extracts FlatGridItemTypes relevant for working with CategorizedProperties | |
FlatGridItem | Type which describes immutable GridCategoryItem or CategorizedPropertyItem | |
Image | Image data returned by an IImageLoader | |
ImageFileFormat | Type of raw image format | |
ImageSourceType | Type of loaded image source: | |
IMutableFlatGridItem | Type which describes mutable GridCategoryItem or CategorizedProperty | |
Observer | Observer interface compatible with rxjs | |
OnItemsDeselectedCallback | ||
OnItemsSelectedCallback | ||
OnSelectionChanged | ||
PropertyCategoryRenderer | ||
PropertyDataChangesListener | ||
PropertyFilter | Type that describes property filter. | Beta |
PropertyFilterChangesListener | ||
PropertyGridModelChangeListener | ||
ShowHideID | Union type for all possible ShowHide IDs | |
SimpleTreeDataProviderHierarchy | Used by SimpleTreeDataProvider. | |
TableDataChangesListener | ||
ToolbarItem | Describes toolbar item. | |
TreeDataChangesListener | ||
TreeDataProvider | Type definition for all BeInspireTree data providers | |
TreeDataProviderMethod | ||
TreeDataProviderPromise | A Promise for TreeDataProviderRaw | |
TreeDataProviderRaw | Array of tree node data elements | |
TreeModelNodeType | Type definition of all tree model nodes. | |
TreeNodeEditorRenderer | ||
TreeNodeItemData | Type definition of tree node item data. |
Last Updated: 30 November, 2023