TableCellProps Interface
Deprecated in 3.0. Use the Table component in @itwin/itwinui-react instead, which does not use this interface.
Properties of the TableCell React component
Extends
Methods
Name |
Description |
|
onClick(e: MouseEvent<Element, MouseEvent>): void Optional |
Click event callback |
|
onMouseDown(e: MouseEvent<Element, MouseEvent>): void Optional |
MouseDown event callback |
|
onMouseMove(e: MouseEvent<Element, MouseEvent>): void Optional |
MouseMove event callback |
|
Properties
Name |
Type |
Description |
|
cellEditingProps |
undefined | Omit<EditorContainerProps, "title"> |
Properties for EditorContainer. |
|
children |
undefined | ReactNode |
Cell content |
|
className |
undefined | string |
Additional class name for the cell container |
|
title |
string |
Title of the cell container |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
itemId |
undefined | string |
CommonProps |
Optional unique identifier for item. |
style |
undefined | CSSProperties |
CommonProps |
Custom CSS style properties |
Defined in
Last Updated:
30 November, 2023