PropertyCategoryLabelFilterer Class
PropertyData filterer which matches on PropertyCategory's label.
Extends
Methods
Name | Description | |
---|---|---|
constructor(filterText: string = ""): PropertyCategoryLabelFilterer | ||
categoryMatchesFilter(node: PropertyCategory): Promise<PropertyDataFilterResult> |
Inherited methods
Name | Inherited from | Description |
---|---|---|
recordMatchesFilter(): Promise<PropertyDataFilterResult> | PropertyCategoryDataFiltererBase |
Properties
Name | Type | Description | |
---|---|---|---|
filterText Accessor | string | ||
isActive Accessor ReadOnly | boolean |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onFilterChanged | PropertyFilterChangeEvent | PropertyCategoryDataFiltererBase |
Defined in
Last Updated: 30 November, 2023