fromTokenString MethodStatic
Create an AccessToken from a string that's typically passed across the wire
- The AccessToken will not include the user information or expiry information
- The token must include the "Bearer" prefix that identifies JSON Web Tokens (JWTs)
- The token is NOT validated in any way other than the basic prefix check described above
fromTokenString(tokenStr: string): AccessToken
throws BentleyError If the token does not have the required prefix
Parameter | Type | Description |
---|---|---|
tokenStr | string | String representation of the token |
Returns - AccessToken
Defined in
- clients/itwin/src/Token.ts Line 134
Last Updated: 12 June, 2024