BentleyError Class
The error type thrown by this module. BentleyError
subclasses Error
to add an errorNumber
member. See IModelStatus for errorNumber
values.
Extends
- Error
Methods
Name | Description | |
---|---|---|
constructor(errorNumber: number, message?: string, log?: LogFunction, category?: string, getMetaData?: GetMetaDataFunction): BentleyError | Construct a new BentleyError | |
_initName(): string Protected | This function returns the name of each error status. | |
getMetaData(): any | Return the meta data associated with this BentleyError. |
Properties
Name | Type | Description | |
---|---|---|---|
errorNumber | number | ||
hasMetaData Accessor ReadOnly | boolean | Returns true if this BentleyError includes (optional) meta data. |
Defined in
- core/bentley/src/BentleyError.ts Line 394
Last Updated: 12 June, 2024