RenderTexture Namespace
Enumeration
Name | Description |
---|---|
RenderTexture.Type | Enumerates the types of RenderTextures. |
Class
Name | Description |
---|---|
RenderTexture.Params | Parameters used to construct a RenderTexture. |
Defined in
- core/common/src/RenderTexture.ts Line 48
RenderTexture Class
Represents a texture image applied to a surface during rendering. A RenderTexture is typically - but not always - associated with a RenderMaterial.
see RenderSystem.createTextureFromImage to obtain a texture from an HTML image.
see RenderSystem.createTextureFromElement to obtain a texture from a Texture element.
Implements
Methods
Name | Description | |
---|---|---|
constructor(params: RenderTexture.Params): RenderTexture Protected | ||
dispose(): void Abstract | Releases any WebGL resources owned by this texture. |
Properties
Name | Type | Description | |
---|---|---|---|
bytesUsed Accessor AbstractReadOnly | number | ||
isGlyph Accessor ReadOnly | boolean | ||
isOwned Readonly | boolean | Indicates that some object is managing the lifetime of this texture and will take care of calling its dispose function appropriately. | |
isSkyBox Accessor ReadOnly | boolean | ||
isTileSection Accessor ReadOnly | boolean | ||
key Readonly | undefined | string | A string uniquely identifying this texture within the context of an IModel. | |
type Readonly | RenderTexture.Type | Indicates the type of texture. |
Defined in
- core/common/src/RenderTexture.ts Line 17
Last Updated: 12 June, 2024