customizeTreeNodeItem Function
Deprecated in 3.x. This is a temporary function to apply deprecated Node customization attributes on a TreeNodeItem.
The recommendation is to switch to using a custom customization function that looks at node's extendedData and applies TreeNodeItem customization based on values in extended data. See extended data usage page for more details.
Applies customization from Node to TreeNodeItem.
customizeTreeNodeItem(item: Partial<DelayLoadedTreeNodeItem>, node: Partial<Node>): void
Parameter | Type | Description |
---|---|---|
item | Partial<DelayLoadedTreeNodeItem> | |
node | Partial<Node> |
Returns - void
Defined in
Last Updated: 30 November, 2023