setActiveMarker Method
Sets the currently active marker. This function is invoked when the user clicks on a marker, but may also be called manually to produce the same result. Changing the active marker first deactivates the currently active marker, if any; then activates the specified marker, if supplied. Returns false if marker activation fails.
setActiveMarker(marker: undefined | SectionMarker): Promise<boolean>
see HyperModelingDecorator.activeMarker to obtain the currently active section marker.
see SectionMarkerHandler.activateMarker to control what happens when a marker is activated.
see SectionMarkerHandler.deactivateMarker to control what happens when a marker is deactivated.
Parameter | Type | Description |
---|---|---|
marker | undefined | SectionMarker |
Returns - Promise<boolean>
Defined in
Last Updated: 30 November, 2023