RecurseToCurvesGeometryHandler Class
Implement GeometryHandler methods, with all curve collection methods recursing to children.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(): RecurseToCurvesGeometryHandler | ||
handleAkimaCurve3d(_g: AkimaCurve3d): any | no-action implementation | |
handleArc3d(_g: Arc3d): any | no-action implementation | |
handleBSplineCurve3d(_g: BSplineCurve3d): any | no-action implementation | |
handleBSplineCurve3dH(_g: BSplineCurve3dH): any | no-action implementation | |
handleBSplineSurface3d(_g: BSplineSurface3d): any | no-action implementation | |
handleBSplineSurface3dH(_g: BSplineSurface3dH): any | no-action implementation | |
handleBagOfCurves(g: BagOfCurves): any | Recurse to children | |
handleBezierCurve3d(_g: BezierCurve3d): any | no-action implementation | |
handleBezierCurve3dH(_g: BezierCurve3dH): any | no-action implementation | |
handleBox(_g: Box): any | no-action implementation | |
handleChildren(g: GeometryQuery): any | Invoke child.dispatchToGeometryHandler(this) for each child in the array returned by the query g.children |
|
handleCone(_g: Cone): any | no-action implementation | |
handleCoordinateXYZ(_g: CoordinateXYZ): any | no-action implementation | |
handleCurveCollection(g: CurveCollection): any | Recurse to children | |
handleIndexedPolyface(_g: IndexedPolyface): any | no-action implementation | |
handleInterpolationCurve3d(_g: InterpolationCurve3d): any | no-action implementation | |
handleLineSegment3d(_g: LineSegment3d): any | no-action implementation | |
handleLineString3d(_g: LineString3d): any | no-action implementation | |
handleLinearSweep(_g: LinearSweep): any | no-action implementation | |
handleLoop(g: Loop): any | Recurse to children | |
handleParityRegion(g: ParityRegion): any | Recurse to children | |
handlePath(g: Path): any | Recurse to children | |
handlePointString3d(_g: PointString3d): any | no-action implementation | |
handleRotationalSweep(_g: RotationalSweep): any | no-action implementation | |
handleRuledSweep(_g: RuledSweep): any | no-action implementation | |
handleSphere(_g: Sphere): any | no-action implementation | |
handleTorusPipe(_g: TorusPipe): any | no-action implementation | |
handleUnionRegion(g: UnionRegion): any | Recurse to children |
Defined in
- geometry3d/GeometryHandler.ts Line 190
Last Updated: 30 November, 2023