CylindricalRangeQuery Class
Context for computing geometry range around an axis.
- The publicly called method is `computeZRRange (ray, geometry)
Extends
Methods
Name | Description | |
---|---|---|
handleArc3d(arc0: Arc3d): any | no-action implementation | |
handleLineSegment3d(segment0: LineSegment3d): void | no-action implementation | |
handleLineString3d(ls0: LineString3d): void | no-action implementation | |
buildRotationalNormalsInLineStrings(geometry: AnyCurve, axis: Ray3d, defaultVectorFromAxis: Vector3d): void Static | Recurse through geometry.children to find linestrings. | |
computeMaxVectorFromRay(ray: Ray3d, geometry: GeometryQuery): Vector3d Static | Compute the largest vector perpendicular to a ray and ending on the geometry. |
Inherited methods
Defined in
- curve/Query/CylindricalRange.ts Line 25
Last Updated: 30 November, 2023