Beta
Properties of ToolSettings component.
Extends
Methods
Name |
Description |
|
onDrag(dragged: PointProps): void Optional |
Function called when widget is dragged. |
|
onDragEnd(): void Optional |
Function called when widget drag action is finished. |
|
onDragStart(initialPosition: PointProps): void Optional |
Function called when widget drag action is started. |
|
onMouseEnter(event: MouseEvent<HTMLElement, MouseEvent>): void Optional |
Handler for mouse enter |
|
onMouseLeave(event: MouseEvent<HTMLDivElement, MouseEvent>): void Optional |
Handler for mouse leave |
|
onResize(resizeBy: number, handle: ResizeHandle): void Optional |
Function called when resize action is performed. |
|
Properties
Name |
Type |
Description |
|
buttons |
undefined | ReactNode |
Title bar buttons. |
|
children |
undefined | ReactNode |
Tool settings content or content container. |
|
contentRef |
undefined | Ref<HTMLDivElement> |
Content ref of this widget. |
|
fillZone |
undefined | boolean |
Describes if the widget should fill the zone. |
|
lastPosition |
undefined | PointProps |
Last pointer position of draggable tab. |
|
title |
undefined | string |
Tool settings title bar title. |
|
Inherited properties
Defined in
Last Updated:
12 June, 2024