ContentLayoutManager Class
ContentLayout Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): ContentLayoutManager | ||
addLayout(layoutId: string, layoutDef: ContentLayoutDef): void Static | Adds a Content Layout. | |
findLayout(layoutId: string): undefined | ContentLayoutDef Static | Finds a Content Layout with a given id. | |
loadLayout(layoutProps: ContentLayoutProps): void Static | Loads a Content Layout. | |
loadLayouts(layoutPropsList: ContentLayoutProps[]): void Static | Loads one or more Content Layouts. | |
refreshActiveLayout(): void Static | Refreshes the active layout and content group. | |
setActiveLayout(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): Promise<void> Static | Sets the active Content Layout, Content Group and Content Control. |
Properties
Name | Type | Description | |
---|---|---|---|
activeContentGroup Accessor StaticReadOnly | undefined | ContentGroup | Gets the active Content Group | |
activeLayout Accessor StaticReadOnly | undefined | ContentLayoutDef | Gets the active Content Layout |
Defined in
Last Updated: 12 June, 2024