DEPRECATED_Tree Class
Deprecated Use ControlledTree instead. Will be removed in iModel.js 3.0.
A Tree React component that uses the core of BeInspireTree but renders with TreeBase and TreeNodeBase from ui-core.
Extends
- Component<TreeProps, TreeState>
Methods
Name | Description | |
---|---|---|
getLoadedNode(id: string): undefined | TreeNodeItem | Get loaded node by its ID | |
shouldComponentUpdate(nextProps: TreeProps, nextState: TreeState): boolean |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps StaticReadonly | Partial<TreeProps> |
Defined in
Last Updated: 12 June, 2024