Name |
Description |
|
ActiveMatchInfo |
Properties for identifying an active highlight on a node in a tree. |
|
BeInspireTreeDataProviderInterface |
Signature for BeInspireTree data provider |
Deprecated |
BeInspireTreeNode |
Type definition for all BeInspireTree nodes |
Deprecated |
BeInspireTreeNodeConfig |
Be alias for Inspire.NodeConfig |
Deprecated |
BeInspireTreeNodeITree |
Be alias for Inspire.NodeConfig.ITree |
Deprecated |
BeInspireTreeNodePayloadConfig |
Data structure for BeInspireTreeNodeConfig with our injected props |
Deprecated |
BeInspireTreeNodes |
Definition of a list of BeInspireTreeNode with some additional filtering methods |
Deprecated |
BeInspireTreeProps |
Configuration properties for BeInspireTree |
Deprecated |
CheckBoxInfo |
Immutable data structure that describes checkbox info. |
|
CheckboxStateChange |
Data structure that describes checkbox state change. |
|
CompletionObserver |
CompletionObserver interface compatible with rxjs |
|
ControlledTreeProps |
Properties for ControlledTree |
|
DelayLoadedTreeNodeItem |
A TreeNodeItem for delay-loaded trees |
|
EditableTreeDataProvider |
EditableTreeDataProvider provides cell editing processing for the Tree. |
|
EditableTreeProps |
Properties for a EditableTreeProps.Tree that has cell editing enabled |
Beta |
ErrorObserver |
ErrorObserver interface compatible with rxjs |
|
ExtendedTreeNodeRendererProps |
Extended properties for TreeNodeRenderer. |
Beta |
HighlightableTreeNodeProps |
Properties for a highlightable TreeNode |
|
HighlightableTreeProps |
Properties for highlighting nodes in a tree. |
|
ImmediatelyLoadedTreeNodeItem |
A TreeNodeItem for immediately loaded trees |
|
ITreeDataProvider |
Interface for a tree data provider class |
|
ITreeImageLoader |
Interface for a tree image loader |
|
ITreeNodeLoader |
Tree node loader which is used to load tree nodes. |
|
ITreeNodeLoaderWithProvider |
Tree node loader which uses TreeDataProvider to load nodes. |
|
LoadedNodeHierarchy |
Data structure that describes hierarchy loaded for parent node. |
|
LoadedNodeHierarchyItem |
Data structure that describes one loaded hierarchy item. |
|
MutableCheckBoxInfo |
Mutable data structure that describes checkbox info. |
|
MutableTreeDataProvider |
MutableTreeDataProvider provides manipulation processing for the Tree. |
Beta |
MutableTreeModelNode |
Mutable data structure that describes tree node. |
|
NextObserver |
NextObserver interface compatible with rxjs |
|
NodeCheckboxProps |
Properties for Checkbox in TreeNode |
Deprecated |
Observable |
Observable interface compatible with rxjs |
|
Subscribable |
Subscribable interface compatible with rxjs |
|
Subscription |
Subscription interface compatible with rxjs |
|
TreeActions |
Tree actions that can be performed on tree. |
|
TreeCellUpdatedArgs |
Arguments for the Tree Cell Updated event callback |
Beta |
TreeCheckboxStateChangeEventArgs |
Data structure that describes tree checkbox state change event payload. |
|
TreeDragDropProps |
Props that are injected to the HOC component. |
Beta |
TreeEditingParams |
Params used for tree node editing. |
|
TreeEventHandlerParams |
Data structure that describes tree event handler params. |
|
TreeEvents |
Tree events that can occur while interacting with tree. |
|
TreeModel |
Data structure that describes tree model. |
|
TreeModelChanges |
Data structure that describes changes which happened to the tree model |
|
TreeModelNode |
Immutable data structure that describes tree node. |
|
TreeModelNodeEditingInfo |
Data structure that holds callbacks used for tree node editing. |
|
TreeModelNodeInput |
Data structure that describes input used to create tree node. |
|
TreeModelNodePlaceholder |
Data structure that describes tree node placeholder. |
|
TreeModelRootNode |
Data structure that describes tree root node. |
|
TreeNodeEditorProps |
Properties for TreeNodeEditor component |
Beta |
TreeNodeEventArgs |
Data structure that describes tree node event payload. |
|
TreeNodeIconProps |
Properties for TreeNodeIcon React component |
Deprecated |
TreeNodeItem |
A node item which can be displayed in a tree. |
|
TreeNodeLoadResult |
Data structure that describes node load result |
|
TreeNodeProps |
Properties for TreeNode React component |
Deprecated |
TreeNodeRendererProps |
Properties for TreeNodeRenderer. |
|
TreeProps |
Properties for the DEPRECATED_Tree component |
Deprecated |
TreeRendererAttributes |
Attributes found on TreeRenderer component |
|
TreeRendererContext |
Context of TreeRenderer component. |
Beta |
TreeRendererProps |
Properties for TreeRenderer component. |
|
TreeSelectionChange |
Data structure that describes tree selection change. |
|
TreeSelectionModificationEventArgs |
Data structure that describes tree selection modification event payload. |
|
TreeSelectionReplacementEventArgs |
Data structure that describes tree selection replacement event payload. |
|
Unsubscribable |
Unsubscribable interface compatible with rxjs |
|
VisibleTreeNodes |
Data structure that describes set of visible tree nodes as a flat list. |
|