remove Method

Overloads
remove(field, projectId?, imodelId?) Deprecated  
remove(field, imodel, scope)  

remove(field, projectId?, imodelId?)

Deprecated  

Removes favorite properties from scopes that there is info about.

remove(field: Field, projectId?: string, imodelId?: string): Promise<void>

Parameter Type Description
field Field Field that contains properties. If field contains multiple properties, all of them will be un-favorited.
projectId string Project Id to additionaly remove favorite properties from project scope, otherwise undefined.
imodelId string iModel Id to additionaly remove favorite properties from iModel scope, otherwise undefined. The projectId must be specified if iModelId is specified.

Returns - Promise<void>



remove(field, imodel, scope)

Removes favorite properties from a scope specified and all the more general scopes.

remove(field: Field, imodel: IModelConnection, scope: FavoritePropertiesScope): Promise<void>

note initializeConnection must be called with the imodel before calling this function.

Parameter Type Description
field Field Field that contains properties. If field contains multiple properties, all of them will be un-favorited.
imodel IModelConnection IModelConnection.
scope FavoritePropertiesScope FavoritePropertiesScope to remove the favorite properties from. It also removes from more general scopes.

Returns - Promise<void>


Defined in

Last Updated: 12 June, 2024