clear Method

Overloads
clear(projectId?, imodelId?) Deprecated  
clear(imodel, scope)  

clear(projectId?, imodelId?)

Deprecated  

Removes all favorite properties from a certain scope.

clear(projectId?: string, imodelId?: string): Promise<void>

Parameter Type Description
projectId string Project Id, if the favorite property is specific to a project, otherwise undefined.
imodelId string iModel Id, if the favorite property is specific to a iModel, otherwise undefined. The projectId must be specified if iModelId is specified.

Returns - Promise<void>



clear(imodel, scope)

Removes all favorite properties from a certain scope.

clear(imodel: IModelConnection, scope: FavoritePropertiesScope): Promise<void>

note initializeConnection must be called with the imodel before calling this function.

Parameter Type Description
imodel IModelConnection IModelConnection.
scope FavoritePropertiesScope FavoritePropertiesScope to remove the favorite properties from.

Returns - Promise<void>


Defined in

Last Updated: 12 June, 2024