StyleOverride Interface
Rule to override default node style and dynamically define a foreground/background colors and a font style for a particular nodes.
see More details
Extends
Properties
Name | Type | Description | |
---|---|---|---|
backColor | undefined | string | Background color that should be used for node. | |
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
fontStyle | undefined | string | Font style that should be used for node. | |
foreColor | undefined | string | Foreground color that should be used for node. | |
ruleType | StyleOverride | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Should this rule should be ignored if there is already an existing |
priority | undefined | number | RuleBase | Defines the order in which presentation rules will be evaluated and executed. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | Schema requirements for this rule. |
Defined in
Last Updated: 12 June, 2024