RepeatableRelationshipStepSpecification Interface
Specification of a single relationship path step.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
count | number | "*" | Number of relationship steps that should be taken. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
direction | Forward | Backward | RelationshipStepSpecification | Relationship direction that should be followed to find the target class. |
relationship | SingleSchemaClassSpecification | RelationshipStepSpecification | Specification of the relationship to use for joining the related instance. |
targetClass | undefined | SingleSchemaClassSpecification | RelationshipStepSpecification | Specification of the target class. |
Defined in
Last Updated: 12 June, 2024