ContentRule Interface
Defines content that's displayed in content controls (table view, property pane, etc.) and the content that's selected in unified selection controls
see More details
Extends
Properties
Name | Type | Description | |
---|---|---|---|
condition | undefined | string | Defines a condition for the rule, which needs to be met in order to execute it. | |
ruleType | Content | Used for serializing to JSON. | |
specifications | ContentSpecification[] | Specifications that define content returned by the rule |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
onlyIfNotHandled | undefined | boolean | RuleBase | Should this rule should be ignored if there is already an existing |
priority | undefined | number | RuleBase | Defines the order in which presentation rules will be evaluated and executed. |
requiredSchemas | undefined | RequiredSchemaSpecification[] | RuleBase | Schema requirements for this rule. |
Defined in
Last Updated: 12 June, 2024