RpcRequest<TResponse> Class
A RPC operation request.
Extended by
Methods
Name | Description | |
---|---|---|
constructor<TResponse>(client: RpcInterface, operation: string, parameters: any[]): RpcRequest<TResponse> | Constructs an RPC request. | |
cancel(): void | ||
computeRetryAfter(attempts: number): number Protected | ||
findParameterOfType<T>(requiredProperties: { T }): undefined | T | Finds the first parameter of a given structural type if present. | |
findTokenPropsParameter(): undefined | IModelRpcProps | Finds the first IModelRpcProps parameter if present. | |
handleUnknownResponse(code: number): void Protected | ||
isHeaderAvailable(_name: string): boolean Protected | Override to describe available headers based on a protocol-specific criteria (such as a CORS whitelist). | |
load(): Promise<RpcSerializedValue> ProtectedAbstract | Override to load response value. | |
recordTransientFault(): void Protected | ||
reject(reason: any): void Protected | ||
resetTransientFaultCount(): void Protected | ||
send(): Promise<number> ProtectedAbstract | Override to send the request. | |
setHeader(name: string, value: string): void ProtectedAbstract | Override to set request header values. | |
setHeaders(): Promise<void> Protected | ||
setLastUpdatedTime(): void Protected | Sets the last updated time for the request. | |
submit(): Promise<void> | ||
current(context: RpcInterface): RpcRequest<any> Static | The request for the current RPC operation. |
Properties
Name | Type | Description | |
---|---|---|---|
_rawPromise Protected | Promise<undefined | Response> | ||
_resolveRaw Protected | (value?: Response | PromiseLike<Response>) => void | ||
_response Protected | undefined | Response | ||
activeRequests Accessor StaticReadOnly | ReadonlyMap<string, RpcRequest<any>> | All RPC requests that are currently in flight. | |
aggregateLoad Accessor StaticReadOnly | RpcOperationsProfile | The aggregate operations profile of all active RPC interfaces. | |
client Readonly | RpcInterface | The RPC client instance for this request. | |
connecting Accessor ReadOnly | boolean | Whether a connection is active for this request. | |
elapsed Accessor ReadOnly | number | The elapsed time for this request. | |
events StaticReadonly | BeEvent<RpcRequestEventHandler> | Events raised by RpcRequest. | |
extendedStatus Accessor ReadOnly | string | Extended status information for this request (if available). | |
id Readonly | string | The unique identifier of this request. | |
lastSubmitted Accessor ReadOnly | number | The last submission for this request. | |
lastUpdated Accessor ReadOnly | number | The last status update received for this request. | |
method | string | A protocol-specific method identifier for this request. | |
notFoundHandlers StaticReadonly | BeEvent<RpcRequestNotFoundHandler> | Resolvers for "not found" requests. | |
operation Readonly | RpcOperation | The operation for this request. | |
parameters | any[] | The parameters for this request. | |
path | string | A protocol-specific path identifier for this request. | |
pending Accessor ReadOnly | boolean | Whether this request is pending. | |
protocol Readonly | RpcProtocol | Convenience access to the protocol of this request. | |
rawResponse Accessor ReadOnly | Promise<undefined | Response> | The raw implementation response for this request. | |
response Readonly | Promise<undefined | TResponse> | The implementation response for this request. | |
retryAfter Accessor ReadOnly | | number | An attempt-specific value for when to next retry this request. | |
retryInterval | number | The target interval (in milliseconds) between submission attempts for this request. | |
status Accessor ReadOnly | RpcRequestStatus | The status of this request. |
Defined in
Last Updated: 12 June, 2024