NativeAppAuthorizationConfiguration Interface
Beta
Client configuration to generate OIDC/OAuth tokens for native applications
Properties
Name | Type | Description | |
---|---|---|---|
clientId Readonly | string | Client application's identifier as registered with the OIDC/OAuth2 provider. | |
expiryBuffer Readonly | undefined | number | Time in seconds that's used as a buffer to check the token for validity/expiry. | |
issuerUrl | undefined | string | The OAuth token issuer URL. | |
redirectUri Readonly | undefined | string | Upon signing in, the client application receives a response from the Bentley IMS OIDC/OAuth2 provider at this URI | |
scope Readonly | string | List of space separated scopes to request access to various resources. |
Defined in
Last Updated: 12 June, 2024