MapLayerProps Interface
Beta
JSON representation of the settings associated with a map layer. One or more map layers may be included within a MapImageryProps object.
see MapImageryProps
Properties
Name | Type | Description | |
---|---|---|---|
accessKey | undefined | MapLayerKey | Access Key for the Layer, like a subscription key or access token | |
formatId | undefined | string | Identifies the map layers source. | |
isBase | undefined | boolean | Is a base layer. | |
name | undefined | string | Name | |
subLayers | undefined | MapSubLayerProps[] | Source layers. | |
transparency | undefined | number | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, | |
transparentBackground | undefined | boolean | True to indicate background is transparent. | |
url | undefined | string | URL | |
visible | undefined | boolean | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 111
Last Updated: 12 June, 2024