HiddenLine.SettingsProps Interface
Describes how visible and hidden edges and transparent surfaces should be rendered in "hidden line" and "solid fill" RenderModes.
Properties
Name | Type | Description | |
---|---|---|---|
hidden Readonly | undefined | HiddenLine.StyleProps | Describes how hidden edges (those obscured by other geometry) should be displayed. | |
transThreshold Readonly | undefined | number | A value in the range [0.0, 1.0] specifying a threshold below which transparent surfaces should not be drawn. | |
visible Readonly | undefined | HiddenLine.StyleProps | Describes how visible edges (those unobscured by other geometry) should be displayed. |
Defined in
- core/common/src/HiddenLine.ts Line 158
Last Updated: 12 June, 2024