requestResourcesForUpdate Method
Beta
Request the locks and/or Codes that will be required to update the specified elements and/or models. This is a convenience method. It builds a request and sends it to the iModel server. It does not update the elements or models.
requestResourcesForUpdate(ctx: AuthorizedClientRequestContext, elements: ElementProps[], models?: ModelProps[], relationships?: RelationshipProps[]): Promise<void>
throws IModelHubError if some or all of the request could not be fulfilled by iModelHub.
throws IModelError if the IModelDb is not open or is not connected to an iModel. See CodeHandler and LockHandler for details on what errors may be thrown. See ConcurrencyControl.requestResources, ConcurrencyControl.requestResourcesForInsert, ConcurrencyControl.requestResourcesForDelete See ConcurrencyControl.Locks.lockModels
Parameter | Type | Description |
---|---|---|
ctx | AuthorizedClientRequestContext | |
elements | ElementProps[] | The elements to lock |
models | ModelProps[] | The models to lock |
relationships | RelationshipProps[] |
Returns - Promise<void>
Defined in
Last Updated: 12 June, 2024