Information about the platform on which the app is running. Also see KnownLocations and IModelJsFs.
Methods
Name |
Description |
|
constructor(): Platform |
|
|
Properties
Name |
Type |
Description |
|
isDesktop Accessor StaticReadOnly |
boolean |
Query if this is a desktop backend |
|
isElectron Accessor StaticReadOnly |
boolean |
Query if this is an electron backend |
|
isMobile Accessor StaticReadOnly |
boolean |
Query if this is a mobile backend |
|
isNodeJs Accessor StaticReadOnly |
boolean |
Query if this is backend running in Node.js |
|
platformName Accessor StaticReadOnly |
"android" | "darwin" | "linux" | "win32" | "ios" | "uwp" |
Get the name of the platform. |
|
Defined in
Last Updated:
12 June, 2024