update Method
Update the named Version of an iModel. Only the description can be changed when updating the named Version.
update(requestContext: AuthorizedClientRequestContext, iModelId: string, version: Version): Promise<Version>
throws IModelHubError with IModelHubStatus.UserDoesNotHavePermission if the user does not have ManageVersions permission.
throws IModelHubError with IModelHubStatus.VersionAlreadyExists if a named Version already exists with the specified name.
throws Common iModelHub errors
Parameter | Type | Description |
---|---|---|
requestContext | AuthorizedClientRequestContext | The client request context. |
iModelId | string | Id of the iModel. See HubIModel. |
version | Version | Named version to update. |
Returns - Promise<Version>
Updated Version instance from iModelHub.
Defined in
Last Updated: 12 June, 2024