collectFaceAreaSummary MethodStatic

Return a summary structure data about face (or other numeric quantity if the caller's areaFunction returns other value)

  • The default areaFunction computes area of polygonal face.
  • Callers with curved edge graphs must supply their own area function.

collectFaceAreaSummary(source: | [], collectAllNodes: boolean = false, areaFunction: = HalfEdgeGraphSearch.signedFaceArea): SignedDataSummary<>

Parameter Type Description
source | [] graph or array of nodes to examine
collectAllNodes boolean flag to pass to the SignedDataSummary constructor to control collection of nodes.
areaFunction function to all to obtain area (or other numeric value)

Returns - SignedDataSummary<>

Defined in

Last Updated: 12 June, 2024