IModelJson.TransitionSpiralProps Interface
Interface for spiral
- Any 4 (but not 5) of the 5 values
[startBearing, endBearing, startRadius, endRadius, length]
may be defined. - In radius data, zero radius indicates straight line (infinite radius)
- Note that the inherited AxesProps allows multiple ways to specify orientation of the placement..
Extends
Properties
Name | Type | Description | |
---|---|---|---|
activeFractionInterval | undefined | number[] | Fractional part of active interval. | |
curveLength | undefined | number | Deprecated synonym for length property. |
Deprecated |
endBearing | undefined | AngleProps | End bearing. | |
endRadius | undefined | number | Radius at end (0 for straight line) | |
fractionInterval | undefined | number[] | DEPRECATED -- use activeFractionInterval. | Deprecated |
intervalFractions | undefined | [number, number] | DEPRECATED -- use activeFractionInterval. | Deprecated |
length | undefined | number | length along curve. | |
origin | XYZProps | origin of the coordinate system. | |
startBearing | undefined | AngleProps | angle at departure from origin. | |
startRadius | undefined | number | Radius at start (0 for straight line) | |
type | undefined | string | TransitionSpiral type. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
xyVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
yawPitchRollAngles | undefined | YawPitchRollProps | IModelJson.AxesProps | See YawPitchAngles class for further information about using 3 rotations to specify orientation. |
zxVectors | undefined | [XYZProps, XYZProps] | IModelJson.AxesProps | Cartesian coordinate directions defined by X direction then Y direction. |
Defined in
- serialization/IModelJsonSchema.ts Line 317
Last Updated: 12 June, 2024