BGFBAccessors.VariantGeometryUnion Enumeration

Members

Name Value Description
tagNONE 0  
tagLineSegment 1  
tagEllipticArc 2  
tagBsplineCurve 3  
tagLineString 4  
tagCurveVector 5  
tagDgnCone 6  
tagDgnSphere 7  
tagDgnTorusPipe 8  
tagDgnBox 9  
tagDgnExtrusion 10  
tagDgnRotationalSweep 11  
tagDgnRuledSweep 12  
tagPolyface 13  
tagBsplineSurface 14  
tagVectorOfVariantGeometry 15  
tagInterpolationCurve 16  
tagTransitionSpiral 17  
tagPointString 18  
tagAkimaCurve 19  
tagCatenaryCurve 20  
tagPartialCurve 21  

Defined in

Last Updated: 12 June, 2024