clipPolyfaceClipPlane MethodStatic

Clip each facet of polyface to the ClipPlane.

  • Return all surviving clip as a new mesh.
  • WARNING: The new mesh is "points only" -- parameters, normals, etc are not interpolated

clipPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane, insideClip: boolean = true, buildClosureFaces: boolean = false): Polyface

Parameter Type Description
polyface Polyface  
clipper ClipPlane  
insideClip boolean  
buildClosureFaces boolean  

Returns - Polyface

Defined in

Last Updated: 12 June, 2024