createMiteredPipeSections MethodStatic

  • Create section arcs for mitered pipe.
  • At each end of each pipe, the pipe is cut by the plane that bisects the angle between successive pipe centerlines.
  • The arc definitions are constructed so that lines between corresponding fractional positions on the arcs are axial lines on the pipes.
    • This means that each arc definition axes (aka vector0 and vector90) are not perpendicular to each other.

createMiteredPipeSections(centerline: IndexedXYZCollection, radius: number): Arc3d[]

Parameter Type Description
centerline IndexedXYZCollection centerline of pipe
radius number radius of arcs

Returns - Arc3d[]

Defined in

Last Updated: 12 June, 2024