interpolatePointAndTangent Method

Return a ray whose ray.origin is interpolated, and ray.direction is the vector between points with a scale factor applied.

interpolatePointAndTangent(fraction: number, other: Point3d, tangentScale: number, result?: Ray3d): Ray3d

Parameter Type Description
fraction number fractional position between points.
other Point3d endpoint of interpolation
tangentScale number scale factor to apply to the startToEnd vector
result Ray3d optional receiver.

Returns - Ray3d

Defined in

Last Updated: 12 June, 2024