getProjects Method
Gets the iTwin project contexts that are accessible to the authorized user.
getProjects(requestContext: AuthorizedClientRequestContext, queryOptions?: ContextRegistryRequestQueryOptions): Promise<Project[]>
Parameter | Type | Description |
---|---|---|
requestContext | AuthorizedClientRequestContext | The client request context |
queryOptions | ContextRegistryRequestQueryOptions | Query options. Use the mapped EC property names in the query strings and not the TypeScript property names. |
Returns - Promise<Project[]>
Resolves to an array of projects.
Defined in
Last Updated: 12 June, 2024