Navigation Widget React component.
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
UNSAFE_componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
UNSAFE_componentWillReceiveProps(nextProps: Readonly<NavigationWidgetPropsEx>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
UNSAFE_componentWillUpdate(nextProps: Readonly<NavigationWidgetPropsEx>, nextState: Readonly<NavigationWidgetState>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional |
ComponentLifecycle |
Catches exceptions generated in descendant components. |
componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
componentWillReceiveProps(nextProps: Readonly<NavigationWidgetPropsEx>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
componentWillUpdate(nextProps: Readonly<NavigationWidgetPropsEx>, nextState: Readonly<NavigationWidgetState>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
forceUpdate(callback?: () => void): void |
Component<NavigationWidgetPropsEx, NavigationWidgetState> |
|
getSnapshotBeforeUpdate(prevProps: Readonly<NavigationWidgetPropsEx>, prevState: Readonly<NavigationWidgetState>): SS | null Optional |
NewLifecycle |
Runs before React applies the result of render to the document, and |
setState<K extends undefined>(state: (prevState: Readonly<NavigationWidgetState>, props: Readonly<NavigationWidgetPropsEx>) => null | S | { T } | null | S | { T }, callback?: () => void): void |
Component<NavigationWidgetPropsEx, NavigationWidgetState> |
|
shouldComponentUpdate(nextProps: Readonly<NavigationWidgetPropsEx>, nextState: Readonly<NavigationWidgetState>, nextContext: any): boolean Optional |
ComponentLifecycle |
Called to determine whether the change in props and state should trigger a re-render. |
Inherited properties
Defined in
Last Updated:
13 June, 2024