StatusBarWidgetControlArgs Interface
Status Bar Widget Control render prop arguments.
Properties
Name | Type | Description | |
---|---|---|---|
isInFooterMode | boolean | Describes whether the footer is in widget or footer mode. | |
onOpenWidget | (widget: StatusBarFieldId) => void | Function called when the widget is being opened or closed. | |
openWidget | StatusBarFieldId | Currently open widget or null if no widget is open. | |
toastTargetRef | React.Ref<HTMLElement> | Element reference to which the toast will animate out to. |
Defined in
Last Updated: 15 June, 2021