React component that displays a context menu at the cursor containing keyboard shortcuts.
Extends
Methods
Name |
Description |
|
componentDidMount(): void |
|
|
componentWillUnmount(): void |
|
|
render(): React.ReactNode |
|
|
Inherited methods
Name |
Inherited from |
Description |
UNSAFE_componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
UNSAFE_componentWillReceiveProps(nextProps: Readonly<CommonProps>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
UNSAFE_componentWillUpdate(nextProps: Readonly<CommonProps>, nextState: Readonly<KeyboardShortcutMenuState>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional |
ComponentLifecycle |
Catches exceptions generated in descendant components. |
componentDidUpdate(prevProps: Readonly<CommonProps>, prevState: Readonly<KeyboardShortcutMenuState>, snapshot?: SS): void Optional |
NewLifecycle |
Called immediately after updating occurs. |
componentWillMount(): void Optional |
DeprecatedLifecycle |
Called immediately before mounting occurs, and before Component#render . |
componentWillReceiveProps(nextProps: Readonly<CommonProps>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called when the component may be receiving new props. |
componentWillUpdate(nextProps: Readonly<CommonProps>, nextState: Readonly<KeyboardShortcutMenuState>, nextContext: any): void Optional |
DeprecatedLifecycle |
Called immediately before rendering when new props or state is received. |
getSnapshotBeforeUpdate(prevProps: Readonly<CommonProps>, prevState: Readonly<KeyboardShortcutMenuState>): SS | null Optional |
NewLifecycle |
Runs before React applies the result of render to the document, and |
shouldComponentUpdate(nextProps: Readonly<CommonProps>, nextState: Readonly<KeyboardShortcutMenuState>, nextContext: any): boolean Optional |
ComponentLifecycle |
Called to determine whether the change in props and state should trigger a re-render. |
Properties
Defined in
Last Updated:
13 June, 2024