KeyboardShortcutContainer Class
Keyboard Shortcut Container
Methods
Name | Description | |
---|---|---|
areKeyboardShortcutsAvailable(): boolean | ||
emptyData(): void | ||
findKey(keyMapKey: string): KeyboardShortcut | undefined | ||
getAvailableKeyboardShortcuts(): KeyboardShortcut[] | ||
registerKey(keyMapKey: string, inShortcut: KeyboardShortcut): KeyboardShortcut | undefined | ||
showShortcutsMenu(): void | ||
generateKeyMapKey(keyboardKey: string, isAltKeyRequired: boolean, isCtrlKeyRequired: boolean, isShiftKeyRequired: boolean): string Static |
Defined in
Last Updated: 13 June, 2024